aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-31 11:34:53 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-31 11:34:53 +0000
commita8e104a660dc214dfdbda1fed25eaa097d661db2 (patch)
tree943b1319a696ac19544da4bf07254e0a8c0fd463 /packages/hal
parent052400b90c12c17e5ec74a04bc7dea43472000b7 (diff)
downloadopenembedded-a8e104a660dc214dfdbda1fed25eaa097d661db2.tar.gz
ohm: sync with poky
Diffstat (limited to 'packages/hal')
-rw-r--r--packages/hal/ohm/.mtn2git_empty0
-rw-r--r--packages/hal/ohm/fix_configure.patch39
-rw-r--r--packages/hal/ohm_git.bb31
3 files changed, 53 insertions, 17 deletions
diff --git a/packages/hal/ohm/.mtn2git_empty b/packages/hal/ohm/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hal/ohm/.mtn2git_empty
diff --git a/packages/hal/ohm/fix_configure.patch b/packages/hal/ohm/fix_configure.patch
new file mode 100644
index 0000000000..e4b774e785
--- /dev/null
+++ b/packages/hal/ohm/fix_configure.patch
@@ -0,0 +1,39 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2007-12-19 13:43:52.000000000 +0000
++++ git/configure.in 2008-03-06 23:59:57.000000000 +0000
+@@ -201,9 +201,6 @@
+ # Like AC_CHECK_HEADER, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_CHECK_X_HEADER, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_CHECK_HEADER([$1],[$2],[$3],[$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -211,9 +208,6 @@
+ # Like AC_TRY_COMPILE, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_TRY_X_COMPILE, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_TRY_COMPILE([$1], [$2], [$3], [$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -224,14 +218,8 @@
+ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LDFLAGS="$LDFLAGS"
+ # ac_save_LIBS="$LIBS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ # note: $X_CFLAGS includes $x_includes
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+- if test \! -z "$libdir" ; then
+- LDFLAGS="$LDFLAGS -L$libdir"
+- fi
+ # note: $X_LIBS includes $x_libraries
+ LDFLAGS="$LDFLAGS $ALL_X_LIBS"
+ AC_CHECK_LIB([$1], [$2], [$3], [$4], [$5])
diff --git a/packages/hal/ohm_git.bb b/packages/hal/ohm_git.bb
index 11fbd1c929..a747c2ff1c 100644
--- a/packages/hal/ohm_git.bb
+++ b/packages/hal/ohm_git.bb
@@ -4,44 +4,41 @@ LICENSE = "LGPL"
DEPENDS = "gtk+ dbus-glib intltool-native hal"
RDEPENDS_${PN} += "udev hal-info"
-SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
+ file://fix_configure.patch;patch=1"
-PV = "0.0+git${SRCDATE}"
-PR = "r2"
+SRCREV = "edfe25d49d67884bf004de7ae0724c162bb5e65e"
+PV = "0.1.2+${PR}+git${SRCREV}"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-EXTRA_OECONF = "--with-distro=debian --without-xauth"
+EXTRA_OECONF = "--with-distro=debian \
+ --without-xauth \
+ --disable-gtk-doc \
+ --disable-docbook-docs"
do_configure_prepend() {
touch gtk-doc.make
}
-do_configure_append() {
- rm config.log
-}
-
OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
OE_LT_RPATH_ALLOW[export]="1"
PACKAGES =+ "libohm ohm-plugin-x11"
-FILES_${PN}-dev += "${libdir}/ohm/*.la \
- ${libdir}/ohm/*.a "
+FILES_${PN}-dev += "${libdir}/ohm/*.a"
FILES_${PN} = "${sysconfdir} \
${bindir}/* \
- ${sbindir}/* \
- ${libdir}/ohm/*.so \
- "
+ ${sbindir}/* \
+ ${libdir}/ohm/*.so \
+ "
FILES_libohm = "${libdir}/libohm.so.*"
FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
${libdir}/ohm/libohm_idle.so \
${sysconfdir}/ohm/plugins.d/x* \
- ${sysconfdir}/ohm/plugins.d/idle* \
- "
-
-
+ ${sysconfdir}/ohm/plugins.d/idle* \
+ "