aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-01-20 14:10:17 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-20 14:10:17 +0000
commitecdf83fac30e8e2652194c50c129864ca74abe3f (patch)
tree97ca4305553b7d4b6d7b7c556f3f7979a5660eec /packages/hal
parente59d40a736d95003de7482519ec978a8727d039a (diff)
downloadopenembedded-ecdf83fac30e8e2652194c50c129864ca74abe3f.tar.gz
hal: merge in HAL bits from Poky
Diffstat (limited to 'packages/hal')
-rw-r--r--packages/hal/files/99_hal1
-rw-r--r--packages/hal/hal_0.5.8.1.bb34
2 files changed, 33 insertions, 2 deletions
diff --git a/packages/hal/files/99_hal b/packages/hal/files/99_hal
new file mode 100644
index 0000000000..f3d477231e
--- /dev/null
+++ b/packages/hal/files/99_hal
@@ -0,0 +1 @@
+d root root 0700 /var/run/hald none
diff --git a/packages/hal/hal_0.5.8.1.bb b/packages/hal/hal_0.5.8.1.bb
index 4b2196f875..dc07d62846 100644
--- a/packages/hal/hal_0.5.8.1.bb
+++ b/packages/hal/hal_0.5.8.1.bb
@@ -8,9 +8,10 @@ RDEPENDS += "udev"
#RDEPENDS_hal-device-manager = "python hal python-pygnome"
RRECOMMENDS = "udev-utils"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
+ file://99_hal"
S = "${WORKDIR}/hal-${PV}"
@@ -24,6 +25,11 @@ EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
--disable-policy-kit \
"
+do_install_append() {
+ install -d ${D}/etc/default/volatiles
+ install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
+}
+
do_stage() {
autotools_stage_all
install -d ${STAGING_LIBDIR}
@@ -31,6 +37,30 @@ do_stage() {
install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
}
+# At the time the postinst runs, dbus might not be setup so only restart if running
+pkg_postinst_hal () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ /etc/init.d/populate-volatile.sh update
+
+ grep haldaemon /etc/group || addgroup haldaemon
+ grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_hal () {
+ deluser haldaemon || true
+ delgroup haldaemon || true
+}
+
#PACKAGES += "hal-device-manager"
#FILES_hal-device-manager = " \