aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-28 11:53:12 +0000
committerKoen Kooi <koen@openembedded.org>2005-06-28 11:53:12 +0000
commit43bbefe53d2e8f4809fe234c2e34c9831c7229eb (patch)
treeb8140e2241d906c2e3423df69884577e5f5cd99f /packages/hal
parent860cc8847c29a49c623316ae6e8b7ac02bd564c9 (diff)
downloadopenembedded-43bbefe53d2e8f4809fe234c2e34c9831c7229eb.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into bitbake.utwente.nl:/home/koen/OE/openembedded 2005/06/28 13:52:52+02:00 utwente.nl!koen gnome-power_0.0.5.bb, libwnck_2.8.1.bb: new file hal_0.5.2.bb: stage libs + headers 2005/06/28 13:08:58+02:00 utwente.nl!koen hal_0.5.2.bb: inherit pkgconfig BKrev: 42c13a28BTxVjEgHqRMV-YVQqJM3SA
Diffstat (limited to 'packages/hal')
-rw-r--r--packages/hal/hal_0.5.2.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/hal/hal_0.5.2.bb b/packages/hal/hal_0.5.2.bb
index fc807a72bf..d02970ed1d 100644
--- a/packages/hal/hal_0.5.2.bb
+++ b/packages/hal/hal_0.5.2.bb
@@ -10,9 +10,16 @@ LICENSE = "GPL LGPL AFL"
SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
S = "${WORKDIR}/hal-${PV}"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
--with-expat=${STAGING_LIBDIR}/.. \
--with-dbus-sys=${sysconfdir}/dbus-1/system.d \
--with-hotplug=${sysconfdir}/hotplug.d"
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
+ install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
+}