aboutsummaryrefslogtreecommitdiffstats
path: root/packages/handsfree
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-06-07 22:29:03 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-06-07 22:29:03 +0000
commit33eb6c68872b8ffeb3866748f88697a5b2019894 (patch)
tree2fb25b5c34d087de38d919be537aaee5fcfbd91d /packages/handsfree
parent5985ddbe12bc40e9f4bebc6f19217705549bac2e (diff)
downloadopenembedded-33eb6c68872b8ffeb3866748f88697a5b2019894.tar.gz
add handsfree 0.1 courtesy Joaquim Duran. closes #1609
Diffstat (limited to 'packages/handsfree')
-rw-r--r--packages/handsfree/.mtn2git_empty0
-rw-r--r--packages/handsfree/files/.mtn2git_empty0
-rw-r--r--packages/handsfree/files/Makefile.patch19
-rw-r--r--packages/handsfree/handsfree_0.1.bb32
4 files changed, 51 insertions, 0 deletions
diff --git a/packages/handsfree/.mtn2git_empty b/packages/handsfree/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/handsfree/.mtn2git_empty
diff --git a/packages/handsfree/files/.mtn2git_empty b/packages/handsfree/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/handsfree/files/.mtn2git_empty
diff --git a/packages/handsfree/files/Makefile.patch b/packages/handsfree/files/Makefile.patch
new file mode 100644
index 0000000000..6ca8dd2698
--- /dev/null
+++ b/packages/handsfree/files/Makefile.patch
@@ -0,0 +1,19 @@
+--- handsfree/old/Makefile 2006-11-21 18:01:13.000000000 +0000
++++ handsfree/Makefile 2006-11-21 14:01:17.000000000 +0000
+@@ -9,12 +9,12 @@
+ # I use a dmixer as default alsa device to mix
+ # the handsfree output with other sound playback
+ #
+-ALSA_PLAY="default"
+-ALSA_REC="plughw:0,0"
++#ALSA_PLAY="default"
++#ALSA_REC="plughw:0,0"
+
+
+-LDFLAGS= -lbluetooth -lasound
+-CFLAGS=-g -Wall -DOSS=0
++#LDFLAGS= -lbluetooth -lasound
++#CFLAGS=-g -Wall -DOSS=0
+
+ all: handsfree headset
+
diff --git a/packages/handsfree/handsfree_0.1.bb b/packages/handsfree/handsfree_0.1.bb
new file mode 100644
index 0000000000..bd909a0140
--- /dev/null
+++ b/packages/handsfree/handsfree_0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Handsfree and Handset Bluetooth tool"
+HOMEPAGE = "http://www.soft.uni-linz.ac.at/_wiki/tiki-index.php?page=ProjectBluezHandsfree"
+SECTION = "network/misc"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS= "bluez-libs alsa-lib"
+PR = "r0"
+
+
+SRC_URI = "\
+ http://www.soft.uni-linz.ac.at/~vogl/bluez/handsfree-040326.tar.gz \
+ file://Makefile.patch;patch=1 \
+"
+S = "${WORKDIR}/handsfree"
+
+# Alsa devices
+# Example: "plughw:0,0"
+ALSA_PLAY = "default"
+ALSA_REC = "default"
+
+CFLAGS =+ "-DOSS=0 "
+LDFLAGS =+ "-lbluetooth -lasound "
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 handsfree ${D}${bindir}
+ install -m 0755 headset ${D}${bindir}
+}