aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hdparm
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-07-23 11:52:57 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-07-23 11:52:57 +0000
commit8e83fdceb8597bdd477f152b8d195e9ab890d29a (patch)
treecb9da4d172b482b54d8e3af98f02679f31009486 /packages/hdparm
parente9caffa5992185464dd8ce0783a82df9e016a19b (diff)
downloadopenembedded-8e83fdceb8597bdd477f152b8d195e9ab890d29a.tar.gz
hdparm: add 6.6
Diffstat (limited to 'packages/hdparm')
-rw-r--r--packages/hdparm/files/.mtn2git_empty0
-rw-r--r--packages/hdparm/files/uclibc.patch (renamed from packages/hdparm/hdparm-6.3/uclibc.patch)0
-rw-r--r--packages/hdparm/hdparm-6.6/.mtn2git_empty0
-rw-r--r--packages/hdparm/hdparm-6.6/bswap.patch37
-rw-r--r--packages/hdparm/hdparm_6.6.bb14
5 files changed, 51 insertions, 0 deletions
diff --git a/packages/hdparm/files/.mtn2git_empty b/packages/hdparm/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hdparm/files/.mtn2git_empty
diff --git a/packages/hdparm/hdparm-6.3/uclibc.patch b/packages/hdparm/files/uclibc.patch
index 495d7491bb..495d7491bb 100644
--- a/packages/hdparm/hdparm-6.3/uclibc.patch
+++ b/packages/hdparm/files/uclibc.patch
diff --git a/packages/hdparm/hdparm-6.6/.mtn2git_empty b/packages/hdparm/hdparm-6.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hdparm/hdparm-6.6/.mtn2git_empty
diff --git a/packages/hdparm/hdparm-6.6/bswap.patch b/packages/hdparm/hdparm-6.6/bswap.patch
new file mode 100644
index 0000000000..6b0506ceb5
--- /dev/null
+++ b/packages/hdparm/hdparm-6.6/bswap.patch
@@ -0,0 +1,37 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- hdparm-5.8/hdparm.c~bswap
++++ hdparm-5.8/hdparm.c
+@@ -20,8 +20,9 @@
+ #include <linux/types.h>
+ #include <linux/hdreg.h>
+ #include <linux/major.h>
+-#include <asm/byteorder.h>
+-//#include <endian.h>
++#include <byteswap.h>
++
++#define le16_to_cpus(x) bswap_16(htons(x))
+
+ #include "hdparm.h"
+
+@@ -1160,7 +1162,7 @@
+ }
+ } else {
+ for(i = 0; i < 0x100; ++i) {
+- __le16_to_cpus(&id[i]);
++ le16_to_cpus(&id[i]);
+ }
+ identify((void *)id, NULL);
+ }
+@@ -1380,7 +1382,7 @@
+ }
+ for (i = 0; count >= 4; ++i) {
+ sbuf[i] = (fromhex(b[0]) << 12) | (fromhex(b[1]) << 8) | (fromhex(b[2]) << 4) | fromhex(b[3]);
+- __le16_to_cpus((__u16 *)(&sbuf[i]));
++ le16_to_cpus((__u16 *)(&sbuf[i]));
+ b += 5;
+ count -= 5;
+ }
diff --git a/packages/hdparm/hdparm_6.6.bb b/packages/hdparm/hdparm_6.6.bb
new file mode 100644
index 0000000000..94d1e6e9bf
--- /dev/null
+++ b/packages/hdparm/hdparm_6.6.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz \
+ file://bswap.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+
+do_install () {
+ install -d ${D}/${sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' install
+}