aboutsummaryrefslogtreecommitdiffstats
path: root/packages/helloworld
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:31:13 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:31:13 +0000
commit435dc70aa0e43b448804045a9aa358856bc67bb8 (patch)
treeda9e14804b9b0a0b0bc0989906fb00525e7dc1bb /packages/helloworld
parentdcd01b049d371444c3ca32639c08db28df8fe400 (diff)
downloadopenembedded-435dc70aa0e43b448804045a9aa358856bc67bb8.tar.gz
helloworld: package plus image for truly minimal user space, a statically linked hello world executable.
Diffstat (limited to 'packages/helloworld')
-rw-r--r--packages/helloworld/.mtn2git_empty0
-rw-r--r--packages/helloworld/helloworld_1.0.0.bb25
2 files changed, 25 insertions, 0 deletions
diff --git a/packages/helloworld/.mtn2git_empty b/packages/helloworld/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/helloworld/.mtn2git_empty
diff --git a/packages/helloworld/helloworld_1.0.0.bb b/packages/helloworld/helloworld_1.0.0.bb
new file mode 100644
index 0000000000..9e68b0bd61
--- /dev/null
+++ b/packages/helloworld/helloworld_1.0.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Minimal statically compiled Hello world!"
+LICENSE = "GPL"
+PR = "r0"
+
+S = "${WORKDIR}/${P}"
+
+do_fetch () {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
+}
+
+do_compile () {
+ ${CC} -o helloworld helloworld.c -static
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}/
+ # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
+ # so if a sysvinit is installed, it will be used instead of helloworld
+ install -d ${D}${base_bindir}
+ ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
+}
+