aboutsummaryrefslogtreecommitdiffstats
path: root/packages/horizon/horizon_cvs.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-30 11:15:50 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-30 11:15:50 +0000
commitd3be917a564f3aee7ee7ad8e09e9edab7929867a (patch)
tree8df8e375d141fc7923de7eb6f781b4cd7f3e4b25 /packages/horizon/horizon_cvs.bb
parentb0e7d9796b0affcd3bf49987f4965a527cb0e5a9 (diff)
downloadopenembedded-d3be917a564f3aee7ee7ad8e09e9edab7929867a.tar.gz
horizon: add cvs version of this cool sketch toy
* still has /media/mmc1/horizon hardcoded
Diffstat (limited to 'packages/horizon/horizon_cvs.bb')
-rw-r--r--packages/horizon/horizon_cvs.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/horizon/horizon_cvs.bb b/packages/horizon/horizon_cvs.bb
new file mode 100644
index 0000000000..d83fbf9868
--- /dev/null
+++ b/packages/horizon/horizon_cvs.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Horizon is a sketchbook application for tablet devices."
+LICENSE = "GPLv2"
+
+DEPENDS = "glib-2.0 libpng jpeg virtual/libsdl"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=horizon \
+ file://makefile.patch;patch=1"
+
+inherit pkgconfig binconfig
+
+S = "${WORKDIR}/horizon"
+PV = "0.37+cvs${SRCDATE}"
+
+PARALLEL_MAKE = ""
+
+CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/SDL -I. -Isrc -L${STAGING_LIBDIR} `PKG_CONFIG_PATH=${STAGING_DATADIR}/pkgconfig pkg-config --cflags glib-2.0 gobject-2.0 libpng`"
+
+do_compile() {
+ #yes, this is a hack to work around a faulty makefile
+ oe_runmake horizon
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 horizon ${D}${bindir}
+}
+