aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hping
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-11-16 03:32:23 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-11-16 03:32:23 +0000
commit29d70de68c596368ee142db2bfcc3eed868423f6 (patch)
tree89513343430593f89a47b3278aa0856be5d8a3f1 /packages/hping
parentff31f83b1c1bf4fa1cc612806c0cc08b3ca2188c (diff)
downloadopenembedded-29d70de68c596368ee142db2bfcc3eed868423f6.tar.gz
hping2 2.0.0rc3: Use the new siteinfo stuff to determine the endianess and
set the appropriate flag rather then manually processing the site file contents to do this.
Diffstat (limited to 'packages/hping')
-rw-r--r--packages/hping/hping2_1.9.9+2.0.0rc3.bb16
1 files changed, 4 insertions, 12 deletions
diff --git a/packages/hping/hping2_1.9.9+2.0.0rc3.bb b/packages/hping/hping2_1.9.9+2.0.0rc3.bb
index 722d3a4425..471be84d29 100644
--- a/packages/hping/hping2_1.9.9+2.0.0rc3.bb
+++ b/packages/hping/hping2_1.9.9+2.0.0rc3.bb
@@ -7,12 +7,12 @@ other features."
HOMEPAGE = "http://www.hping.org/"
SECTION = "console/network"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.hping.org/hping2.0.0-rc3.tar.gz \
file://hping2_debian.patch;patch=1 \
file://hping2_configure.patch;patch=1"
-S="${WORKDIR}/hping2-rc3"
+S = "${WORKDIR}/hping2-rc3"
#
# We've patched configure to accept byte order and ostype as env
@@ -21,16 +21,8 @@ S="${WORKDIR}/hping2-rc3"
# NOTE: The configure script is not an autoconf script.
#
do_configure() {
- # endianness fun.. inspired by openssl.inc
- . ${CONFIG_SITE}
- BYTEORDER="UNKNOWN"
- if [ "x$ac_cv_c_bigendian" = "xyes" -o "x$ac_cv_c_littleendian" = "xno" ]; then
- BYTEORDER="__BIG_ENDIAN_BITFIELD"
- elif [ "x$ac_cv_c_littleendian" = "xyes" -o "x$ac_cv_c_bigendian" = "xno" ]; then
- BYTEORDER="__LITTLE_ENDIAN_BITFIELD"
- else
- oefatal do_configure cannot determine endianess
- fi
+ # Additional flag based on target endiness (see siteinfo.bbclass)
+ BYTEORDER="${@base_conditional('SITEINFO_ENDIANESS', 'le', '__LITTLE_ENDIAN_BITFIELD', '__BIG_ENDIAN_BITFIELD', d)}"
oenote Determined byteorder as: $BYTEORDER
BYTEORDER="${BYTEORDER}" CONFIGOSTYPE="LINUX" ./configure
}