aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hping
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-08-16 14:54:39 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-08-16 14:54:39 +0000
commitbc103273ecb7a2aacd1d796de36e3b066a46d1f0 (patch)
tree027a12b4d85ededafe7a4d88359ca1d8bb0e13fe /packages/hping
parentca434073387b648f2644cc87425619a930e0a224 (diff)
downloadopenembedded-bc103273ecb7a2aacd1d796de36e3b066a46d1f0.tar.gz
hping2 2.0.0rc3: Update the endianess test to handle the situation where only
{big,litte}endian is set to "no" and neither of them is set to "yes". Saying it's "not big endian" seems a bit backwards but that's what some site files seem to get by with. Same fix as for net-snmp as per #1320.
Diffstat (limited to 'packages/hping')
-rw-r--r--packages/hping/hping2_1.9.9+2.0.0rc3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/hping/hping2_1.9.9+2.0.0rc3.bb b/packages/hping/hping2_1.9.9+2.0.0rc3.bb
index 912f7c420e..cedcf975f9 100644
--- a/packages/hping/hping2_1.9.9+2.0.0rc3.bb
+++ b/packages/hping/hping2_1.9.9+2.0.0rc3.bb
@@ -24,14 +24,15 @@ S="${WORKDIR}/hping2-rc3"
do_configure() {
# endianness fun.. inspired by openssl.inc
. ${CONFIG_SITE}
- BYTEORDER="UNKNOWN"
- if test "x$ac_cv_c_bigendian" = "xyes"; then
+ BYTEORDER="UNKNOWN"
+ if [ "x$ac_cv_c_bigendian" = "xyes" -o "x$ac_cv_c_littleendian" = "xno" ]; then
BYTEORDER="__BIG_ENDIAN_BITFIELD"
- elif test "x$ac_cv_c_littleendian" = "xyes"; then
+ elif [ "x$ac_cv_c_littleendian" = "xyes" -o "x$ac_cv_c_bigendian" = "xno" ]; then
BYTEORDER="__LITTLE_ENDIAN_BITFIELD"
else
oefatal do_configure cannot determine endianess
fi
+ oenote Determined byteorder as: $BYTEORDER
BYTEORDER="${BYTEORDER}" CONFIGOSTYPE="LINUX" ./configure
}