aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ica
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 01:34:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 01:34:41 +0000
commitdcce5a4e4a05b0493375a2363511a846b98b40cc (patch)
tree3a066e5af614010e76f040145885449e1c864264 /packages/ica
parent4d7df24aeacecc435b4311f7771c4c2c7e8c57f4 (diff)
downloadopenembedded-dcce5a4e4a05b0493375a2363511a846b98b40cc.tar.gz
ica: initial add
Diffstat (limited to 'packages/ica')
-rw-r--r--packages/ica/.mtn2git_empty0
-rw-r--r--packages/ica/ica-bin_8.0.bb55
2 files changed, 55 insertions, 0 deletions
diff --git a/packages/ica/.mtn2git_empty b/packages/ica/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ica/.mtn2git_empty
diff --git a/packages/ica/ica-bin_8.0.bb b/packages/ica/ica-bin_8.0.bb
new file mode 100644
index 0000000000..b8afd1aaa5
--- /dev/null
+++ b/packages/ica/ica-bin_8.0.bb
@@ -0,0 +1,55 @@
+# ica-bin OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DEPENDS="x11 xaw rpm2cpio-native"
+
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+HOMEPAGE="www.citrix.com/download/"
+
+SRC_URI="file://${DL_DIR}/ICAClient-8.0-1.i386.rpm"
+
+S="${WORKDIR}"
+PACKAGES= "${PN}"
+FILES_${PN} = "/"
+
+python ica_do_fetch() {
+ import os
+ def dowarn(str,d):
+ out = bb.data.expand(str, d)
+ bb.note(out)
+
+ file = bb.data.getVar('A', d)
+ basen = os.path.basename(file)
+
+ if not os.path.exists(file):
+ dowarn('You need to perform the following steps to build this package:',d)
+ dowarn('Sign up at ${HOMEPAGE}',d)
+ dowarn('- Download %s and place it in ${DL_DIR}' % basen,d)
+ dowarn('- make this package again',d)
+ raise bb.build.FuncFailed('Package not downloaded')
+}
+
+python do_fetch() {
+ bb.build.exec_func('ica_do_fetch', d)
+ bb.build.exec_func('base_do_fetch', d)
+}
+
+do_unpack() {
+ rpm2cpio.pl ${A} | cpio -i --make-directories
+}
+
+do_compile() {
+}
+
+DDIR="${D}/usr/lib/ICAClient"
+
+do_install () {
+ for file in `find usr/lib/ICAClient/ -type d`; do
+ install -d ${D}/$file
+ done
+
+ for file in `find usr/lib/ICAClient/ -type f`; do
+ install $file ${D}/$file
+ done
+}