aboutsummaryrefslogtreecommitdiffstats
path: root/packages/icewm
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 16:08:32 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 16:08:32 +0000
commit1e6438c6cb5d855c836018d621be963eed44ae11 (patch)
treec4f3db8c2366133c9fffd0bc23d9f1eddd7d99a7 /packages/icewm
parentcbe58c1e1ca9714d8dd7fcd6391a4dd45ced0936 (diff)
downloadopenembedded-1e6438c6cb5d855c836018d621be963eed44ae11.tar.gz
icewm - configure patch for using pkgconfig to find libxft.
- point to correct X includes, libs, and mkfontdir-native. - upgrade to icewm version 1.2.26.
Diffstat (limited to 'packages/icewm')
-rw-r--r--packages/icewm/icewm-1.2.20/configure.patch68
-rw-r--r--packages/icewm/icewm-1.2.26/.mtn2git_empty0
-rw-r--r--packages/icewm/icewm-1.2.26/configure.patch22
-rw-r--r--packages/icewm/icewm-1.2.26/makefile.patch26
-rw-r--r--packages/icewm/icewm_1.2.20.bb11
-rw-r--r--packages/icewm/icewm_1.2.26.bb25
6 files changed, 148 insertions, 4 deletions
diff --git a/packages/icewm/icewm-1.2.20/configure.patch b/packages/icewm/icewm-1.2.20/configure.patch
new file mode 100644
index 0000000000..d6071bf260
--- /dev/null
+++ b/packages/icewm/icewm-1.2.20/configure.patch
@@ -0,0 +1,68 @@
+--- icewm-1.2.20/configure.in.orig 2006-06-17 18:03:43.000000000 -0600
++++ icewm-1.2.20/configure.in 2006-06-17 18:03:45.000000000 -0600
+@@ -426,32 +426,43 @@
+ AC_MSG_ERROR("xfreetype or core fonts must be enabled")
+ fi
+ if test "$enable_xfreetype" != "no" -o "$enable_xfreetype" = "implied"; then
+- AC_PATH_PROG(XFT_CONFIG, xft-config,, ${with_xft_arg-${PATH}})
+- if test "${XFT_CONFIG}" != ""; then
+- XFT_CFLAGS=`${XFT_CONFIG} --cflags`
+- XFT_LIBS=`${XFT_CONFIG} --libs`
+- AC_DEFINE(CONFIG_XFREETYPE, 2, [Define to enable XFreeType support.])
+- CORE_CFLAGS="${CORE_CFLAGS} $XFT_CFLAGS"
+- CORE_LIBS="${CORE_LIBS} $XFT_LIBS"
+- features="${features} xfreetype"
+- else
+- AC_CHECK_HEADERS(X11/Xft/Xft.h,
+- [ AC_CHECK_LIB(Xft, XftDrawCreate,
+- [ AC_DEFINE(CONFIG_XFREETYPE, 1, [Define to enable XFreeType support.])
+- CORE_LIBS="${CORE_LIBS} -lXft"
+- enable_corefonts=yes
+- features="${features} xfreetype" ],
+- [ if test "$enable_xfreetype" != "implied"; then
+- AC_MSG_ERROR([Xft support has been requested but libraries were not found.
++ AC_PATH_PROG(PKG_CONFIG, pkg-config)
++
++ if test "${PKG_CONFIG}" != ""; then
++ XFT_CFLAGS=`${PKG_CONFIG} xft --cflags`
++ XFT_LIBS=`${PKG_CONFIG} xft --libs`
++ AC_DEFINE(CONFIG_XFREETYPE, 2, [Define to enable XFreeType support.])
++ CORE_CFLAGS="${CORE_CFLAGS} $XFT_CFLAGS"
++ CORE_LIBS="${CORE_LIBS} $XFT_LIBS"
++ features="${features} xfreetype"
++ else
++ AC_PATH_PROG(XFT_CONFIG, xft-config,, ${with_xft_arg-${PATH}})
++ if test "${XFT_CONFIG}" != ""; then
++ XFT_CFLAGS=`${XFT_CONFIG} --cflags`
++ XFT_LIBS=`${XFT_CONFIG} --libs`
++ AC_DEFINE(CONFIG_XFREETYPE, 2, [Define to enable XFreeType support.])
++ CORE_CFLAGS="${CORE_CFLAGS} $XFT_CFLAGS"
++ CORE_LIBS="${CORE_LIBS} $XFT_LIBS"
++ features="${features} xfreetype"
++ else
++ AC_CHECK_HEADERS(X11/Xft/Xft.h,
++ [ AC_CHECK_LIB(Xft, XftDrawCreate,
++ [ AC_DEFINE(CONFIG_XFREETYPE, 1, [Define to enable XFreeType support.])
++ CORE_LIBS="${CORE_LIBS} -lXft"
++ enable_corefonts=yes
++ features="${features} xfreetype" ],
++ [ if test "$enable_xfreetype" != "implied"; then
++ AC_MSG_ERROR([Xft support has been requested but libraries were not found.
+ *** Configure your X server to support XFreeType.
+ *** Information about how to do this can be found in RELNOTES for XFree86.])
+- fi ])],
+- [ if test "$enable_xfreetype" != "implied"; then
+- AC_MSG_ERROR([Xft support has been requested but headers were not found.
++ fi ])],
++ [ if test "$enable_xfreetype" != "implied"; then
++ AC_MSG_ERROR([Xft support has been requested but headers were not found.
+ *** Configure your X server to support XFreeType.
+ *** Information about how to do this can be found in RELNOTES for XFree86.])
+- fi ])
+- fi
++ fi ])
++ fi
++ fi
+ fi
+
+ if test "$enable_corefonts" = "yes"; then
diff --git a/packages/icewm/icewm-1.2.26/.mtn2git_empty b/packages/icewm/icewm-1.2.26/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/icewm/icewm-1.2.26/.mtn2git_empty
diff --git a/packages/icewm/icewm-1.2.26/configure.patch b/packages/icewm/icewm-1.2.26/configure.patch
new file mode 100644
index 0000000000..ade427d5e0
--- /dev/null
+++ b/packages/icewm/icewm-1.2.26/configure.patch
@@ -0,0 +1,22 @@
+--- icewm-1.2.26/configure.in.orig 2006-07-18 15:16:37.024817360 -0600
++++ icewm-1.2.26/configure.in 2006-07-18 15:17:32.889324664 -0600
+@@ -426,14 +426,11 @@
+ AC_MSG_ERROR("xfreetype or core fonts must be enabled")
+ fi
+ if test "$enable_xfreetype" != "no" -o "$enable_xfreetype" = "implied"; then
+- AC_PATH_PROG(XFT_CONFIG, xft-config,, ${with_xft_arg-${PATH}})
+- if test "${XFT_CONFIG}" == ""; then
+- AC_PATH_PROG(PKG_CONFIG, pkg-config)
+- if test "${PKG_CONFIG}" != ""; then
+- ${PKG_CONFIG} xft 2>/dev/null
+- if test $? -eq 0 ; then
+- XFT_CONFIG='pkg-config xft'
+- fi
++ AC_PATH_PROG(PKG_CONFIG, pkg-config)
++ if test "${PKG_CONFIG}" != ""; then
++ ${PKG_CONFIG} xft 2>/dev/null
++ if test $? -eq 0 ; then
++ XFT_CONFIG='pkg-config xft'
+ fi
+ fi
+ if test "${XFT_CONFIG}" != ""; then
diff --git a/packages/icewm/icewm-1.2.26/makefile.patch b/packages/icewm/icewm-1.2.26/makefile.patch
new file mode 100644
index 0000000000..9473c9b2a9
--- /dev/null
+++ b/packages/icewm/icewm-1.2.26/makefile.patch
@@ -0,0 +1,26 @@
+--- ./src/Makefile.in 2005-02-01 21:56:08.000000000 +0100
++++ ./src/Makefile.in 2005-02-01 21:55:12.000000000 +0100
+@@ -206,10 +206,21 @@
+ %.o: %.cc
+ @echo " CXX " $@
+ @$(CXX) $(CXXFLAGS) $(GCCDEP) -c $<
+-
+-genpref $(BINARIES):
++
++HOSTCXX=g++
++HOSTLD=g++
++
++genpref.o: genpref.cc
++ @echo " HOSTCXX " $@
++ @$(HOSTCXX) $(CXXFLAGS) $(GCCDEP) -c $<
++
++$(BINARIES):
+ @echo " LD " $@
+ @$(LD) -o $@$(EXEEXT) $($@_OBJS) $(LFLAGS) $($@_LFLAGS) $(LIBS) $($@_LIBS)
++
++genpref:
++ @echo " HOSTLD " $@
++ @$(HOSTLD) -o $@$(EXEEXT) $($@_OBJS) $(LFLAGS) $($@_LFLAGS) $(LIBS) $($@_LIBS)
+
+ ################################################################################
+
diff --git a/packages/icewm/icewm_1.2.20.bb b/packages/icewm/icewm_1.2.20.bb
index ff6434279b..dfe87335b3 100644
--- a/packages/icewm/icewm_1.2.20.bb
+++ b/packages/icewm/icewm_1.2.20.bb
@@ -1,17 +1,20 @@
SECTION = "x11/wm"
DESCRIPTION = "IceWM Window Manager"
LICENSE = "GPL"
-DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft"
+DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft mkfontdir-native"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/icewm/icewm-${PV}.tar.gz \
- file://makefile.patch;patch=1"
+ file://makefile.patch;patch=1 \
+ file://configure.patch;patch=1"
S = "${WORKDIR}/icewm-${PV}"
inherit autotools pkgconfig
-EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} \
+ --with-mkfontdir=${STAGING_DIR}/${BUILD_SYS}/bin/mkfontdir"
pkg_postinst() {
update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/icewm-session 10
@@ -19,4 +22,4 @@ update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bi
pkg_postrm() {
update-alternatives --remove x-window-manager /usr/bin/icewm-session
-} \ No newline at end of file
+}
diff --git a/packages/icewm/icewm_1.2.26.bb b/packages/icewm/icewm_1.2.26.bb
new file mode 100644
index 0000000000..7c1e2a2bf7
--- /dev/null
+++ b/packages/icewm/icewm_1.2.26.bb
@@ -0,0 +1,25 @@
+SECTION = "x11/wm"
+DESCRIPTION = "IceWM Window Manager"
+LICENSE = "GPL"
+DEPENDS = "libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft mkfontdir-native"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/icewm/icewm-${PV}.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/icewm-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} \
+ --with-mkfontdir=${STAGING_DIR}/${BUILD_SYS}/bin/mkfontdir"
+
+pkg_postinst() {
+update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/icewm-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager /usr/bin/icewm-session
+}