aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ifupdown
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/ifupdown
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/ifupdown')
-rw-r--r--packages/ifupdown/ifupdown_0.6.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/ifupdown/ifupdown_0.6.4.bb b/packages/ifupdown/ifupdown_0.6.4.bb
index e69de29bb2..e2d21f10d4 100644
--- a/packages/ifupdown/ifupdown_0.6.4.bb
+++ b/packages/ifupdown/ifupdown_0.6.4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "High level tools to configure network interfaces \
+This package provides the tools ifup and ifdown which may be used to \
+configure (or, respectively, deconfigure) network interfaces, based on \
+the file /etc/network/interfaces."
+LICENSE = "GPL"
+
+SECTION = "base"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/i/ifupdown/ifupdown_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/i/ifupdown/ifupdown_${PV}-4.8.diff.gz;patch=1 \
+ file://busybox.patch;patch=1 \
+ file://udhcpc.patch;patch=1 \
+ file://zeroconf.patch;patch=1 \
+ file://gcc34-fix.patch;patch=1 \
+ file://init \
+ file://interfaces"
+
+EXTRA_OEMAKE = ""
+
+do_compile () {
+ chmod a+rx *.pl *.sh
+ oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
+}
+
+do_install () {
+ install -d ${D}/${sysconfdir}/init.d \
+ ${D}/${sysconfdir}/network \
+ ${D}/${base_sbindir}
+ install -m 0755 ifup ${D}/${base_sbindir}/
+ ln ${D}/${base_sbindir}/ifup ${D}/${base_sbindir}/ifdown
+ install -m 0644 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/networking
+ install -m 0644 ${WORKDIR}/interfaces ${D}/${sysconfdir}/network/interfaces
+}