aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images/slugos-image.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-01-23 02:21:17 +0000
committerRod Whitby <rod@whitby.id.au>2007-01-23 02:21:17 +0000
commit2d96dd3d8722c5260740717f70c442b4cb445aac (patch)
tree5e6cb2b464d9b3fdbad03677918b781d5b4018df /packages/images/slugos-image.bb
parent79ebe7b06aa1dd508d80ef4bb040a37d6bc314a9 (diff)
downloadopenembedded-2d96dd3d8722c5260740717f70c442b4cb445aac.tar.gz
ixp4xx (and related ixp4xx-specific files): Change all usage of ARCH_BYTE_SEX to IXP4XX_MACHINE_ENDIAN (and ensure COMPATIBLE_MACHINE is in effect whereever it is used). Add the nslu2le and nslu2be machines. Change include/ixp4xx.conf to use tune-xscale and tune-thumb. Remove slugos-specific variables that had global OE equivalents. Deprecate ixp4xx.conf and nslu2.conf in favour of endian-specific replacements.
Diffstat (limited to 'packages/images/slugos-image.bb')
-rw-r--r--packages/images/slugos-image.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index cf7d580928..a0be935613 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -123,7 +123,7 @@ slugos_pack_image() {
${STAGING_LIBDIR}/nslu2-binaries/SysConf \
${DEPLOY_DIR_IMAGE}/slug/
install -m 0644 ${STAGING_LOADER_DIR}/apex.bin ${DEPLOY_DIR_IMAGE}/slug/
- install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-nslu2${ARCH_BYTE_SEX} \
+ install -m 0644 ${DEPLOY_DIR_IMAGE}/zImage-nslu2${IXP4XX_MACHINE_ENDIAN} \
${DEPLOY_DIR_IMAGE}/slug/vmlinuz
install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
${DEPLOY_DIR_IMAGE}/slug/flashdisk.jffs2
@@ -137,7 +137,7 @@ slugos_pack_image() {
# Create an image for the DSM-G600 as well
install -d ${DEPLOY_DIR_IMAGE}/firmupgrade
- install -m 0755 ${DEPLOY_DIR_IMAGE}/zImage-dsmg600${ARCH_BYTE_SEX} \
+ install -m 0755 ${DEPLOY_DIR_IMAGE}/zImage-dsmg600${IXP4XX_MACHINE_ENDIAN} \
${DEPLOY_DIR_IMAGE}/firmupgrade/ip-ramdisk
install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
${DEPLOY_DIR_IMAGE}/firmupgrade/rootfs.gz
@@ -154,7 +154,7 @@ slugos_pack_image() {
# Create an image for the NAS 100d as well
install -d ${DEPLOY_DIR_IMAGE}/firmupgrade
- install -m 0755 ${DEPLOY_DIR_IMAGE}/zImage-nas100d${ARCH_BYTE_SEX} \
+ install -m 0755 ${DEPLOY_DIR_IMAGE}/zImage-nas100d${IXP4XX_MACHINE_ENDIAN} \
${DEPLOY_DIR_IMAGE}/firmupgrade/ip-ramdisk
install -m 0644 ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
${DEPLOY_DIR_IMAGE}/firmupgrade/rootfs.gz