aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-04 11:22:01 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-04 11:22:42 +0100
commita52a9c2799bf0b856d262a040e6133131883930a (patch)
treedfafb4246ca3cf77045b0fbf2a48492e09f75dcc /packages/images
parent3ff5572d2b2702b8dc925e04ebd2c21d2ae8e8ce (diff)
downloadopenembedded-a52a9c2799bf0b856d262a040e6133131883930a.tar.gz
fso-illume-image: new recipe; An fso-compliant bare illume image as a starting point for X-based applications
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/fso-illume-image.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/packages/images/fso-illume-image.bb b/packages/images/fso-illume-image.bb
new file mode 100644
index 0000000000..979adf1855
--- /dev/null
+++ b/packages/images/fso-illume-image.bb
@@ -0,0 +1,82 @@
+#------------------------------------------------------
+# FSO compliant Illume Image Recipe
+#------------------------------------------------------
+
+require fso-image.bb
+
+PV = "1.0"
+PR = "r1"
+
+# no languages for now
+IMAGE_LINGUAS = ""
+
+BASE_INSTALL = "\
+ task-base \
+"
+
+ILLUME_THEME = "illume-theme-fso"
+
+X_INSTALL = "\
+ task-x11-illume \
+ task-fonts-truetype-core \
+"
+
+X_INSTALL_append_om-gta02 = "\
+ task-fonts-truetype-chinese \
+ task-fonts-truetype-japanese \
+"
+
+# tools
+TOOLS_INSTALL = "\
+ task-cli-tools \
+ task-cli-tools-python \
+"
+
+# audio
+AUDIO_INSTALL = "\
+ alsa-oss \
+ alsa-state \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ gst-meta-audio \
+ gst-plugin-modplug \
+ gst-plugin-sid \
+ fso-sounds \
+"
+
+GTK_INSTALL = "\
+ xterm \
+ gpe-scap \
+"
+
+# FIXME these should rather be part of alsa-state,
+# once Om stabilizes them...
+AUDIO_INSTALL_append_om-gta01 = "\
+ openmoko-alsa-scenarios \
+"
+AUDIO_INSTALL_append_om-gta02 = "\
+ openmoko-alsa-scenarios \
+"
+
+# python
+PYTHON_INSTALL = "\
+ task-python-efl \
+ python-codecs \
+ python-gst \
+"
+
+# fso
+FSO_INSTALL = "\
+ task-fso-compliance \
+"
+
+IMAGE_INSTALL = "\
+ ${BASE_INSTALL} \
+ ${X_INSTALL} \
+ ${GTK_INSTALL} \
+ ${GAMES_INSTALL} \
+ ${AUDIO_INSTALL} \
+ ${TOOLS_INSTALL} \
+ ${PYTHON_INSTALL} \
+ ${FSO_INSTALL} \
+"