aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2006-07-31 04:35:05 +0000
committerMike Westerhof <mwester@dls.net>2006-07-31 04:35:05 +0000
commit38dc18977fc9babb161f90a83cf17441f79aafa3 (patch)
treee7785f10bc261e09a08c4253bafff964757d6b50 /packages/images
parentc59cd456edd96f66ca2d271df0588b53c81dc77c (diff)
downloadopenembedded-38dc18977fc9babb161f90a83cf17441f79aafa3.tar.gz
Unslung image: clean up .dbg files left by changed RUNSTRIP functionality
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/unslung-image.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index e57960ecdb..4d7958741c 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,5 +1,5 @@
LICENSE = MIT
-PR = "r17"
+PR = "r18"
IMAGE_BASENAME = "unslung"
@@ -80,6 +80,21 @@ unslung_clean_image () {
rm -f ${IMAGE_ROOTFS}/usr/bin/locate
rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
+
+ # FIXME: change made 24 Jul 2006 by the OE folks changes the "strip"
+ # behavior to create an extra file named <filename>.dbg containing
+ # the stripped symbols. These dbg files are supposed to be packaged
+ # separately by the standard bb routines, but for some reason this
+ # does not alway occur. This extremely ugly step is to remove the
+ # dbg cruft from the rootfs if any are left in the obvious locations.
+ # Once someone figures out why and what the right way is to fix this,
+ # this code should be removed.
+
+ rm -f ${IMAGE_ROOTFS}/bin/*.dbg
+ rm -f ${IMAGE_ROOTFS}/sbin/*.dbg
+ rm -f ${IMAGE_ROOTFS}/usr/bin/*.dbg
+ rm -f ${IMAGE_ROOTFS}/usr/sbin/*.dbg
+ rm -f ${IMAGE_ROOTFS}/lib/*.dbg
}
python () {