aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2006-08-01 03:23:22 +0000
committerMike Westerhof <mwester@dls.net>2006-08-01 03:23:22 +0000
commit83c9e49ff14d0d023c04823dea2da2ea62caf59c (patch)
treedae759428ba7f7f1a530d3da39727f31c018ca6e /packages/images
parent3da9a257c6618a0300eb69c828d0213555ec5fcf (diff)
downloadopenembedded-83c9e49ff14d0d023c04823dea2da2ea62caf59c.tar.gz
Unslung: unslung_image.bb - .dbg files that need manual cleanup have moved to a .debug directory
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/unslung-image.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index 4d7958741c..701e7f17ea 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,5 +1,5 @@
LICENSE = MIT
-PR = "r18"
+PR = "r19"
IMAGE_BASENAME = "unslung"
@@ -82,19 +82,20 @@ unslung_clean_image () {
rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
# FIXME: change made 24 Jul 2006 by the OE folks changes the "strip"
- # behavior to create an extra file named <filename>.dbg containing
- # the stripped symbols. These dbg files are supposed to be packaged
+ # behavior to create an extra file named .debug/<filename> containing
+ # the stripped symbols. These files are supposed to be packaged
# separately by the standard bb routines, but for some reason this
# does not alway occur. This extremely ugly step is to remove the
- # dbg cruft from the rootfs if any are left in the obvious locations.
+ # debug cruft from the rootfs if any are left in the obvious locations.
# Once someone figures out why and what the right way is to fix this,
# this code should be removed.
- rm -f ${IMAGE_ROOTFS}/bin/*.dbg
- rm -f ${IMAGE_ROOTFS}/sbin/*.dbg
- rm -f ${IMAGE_ROOTFS}/usr/bin/*.dbg
- rm -f ${IMAGE_ROOTFS}/usr/sbin/*.dbg
- rm -f ${IMAGE_ROOTFS}/lib/*.dbg
+ rm -rf ${IMAGE_ROOTFS}/bin/.debug
+ rm -rf ${IMAGE_ROOTFS}/sbin/.debug
+ rm -rf ${IMAGE_ROOTFS}/lib/.debug
+ rm -rf ${IMAGE_ROOTFS}/usr/bin/.debug
+ rm -rf ${IMAGE_ROOTFS}/usr/sbin/.debug
+ rm -rf ${IMAGE_ROOTFS}/usr/lib/.debug
}
python () {