aboutsummaryrefslogtreecommitdiffstats
path: root/packages/initscripts
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-08-22 04:39:50 +0000
committerMike Westerhof <mwester@dls.net>2008-08-22 04:39:50 +0000
commit064d9f29930b20b45d0a68691b7bed49e1707aad (patch)
tree67f9c15c49501f9afc43c701b049f0c9a10d7002 /packages/initscripts
parentc367c54adc09d21456cef634f3460ebc15406c95 (diff)
downloadopenembedded-064d9f29930b20b45d0a68691b7bed49e1707aad.tar.gz
slugOS 5.0 is born - initial commit.
- enable many busybox options - replace several packages in rootfs with busybox, and adjust various config files and scripts to accomodate busybox options - change default alignment behavior to be more lenient Note: this is the first of many disruptive changes for SlugOS 5; this version is to be considered unstable at best!
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/alignment.sh2
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/bootclean.sh4
-rw-r--r--packages/initscripts/initscripts-slugos_1.0.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/packages/initscripts/initscripts-1.0/slugos/alignment.sh b/packages/initscripts/initscripts-1.0/slugos/alignment.sh
index bf193cb01c..52e43cc0c5 100644
--- a/packages/initscripts/initscripts-1.0/slugos/alignment.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/alignment.sh
@@ -14,7 +14,7 @@
# Set ALIGN in /etc/default/rcS to override (do not edit this
# file!) Set ALIGN to empty to avoid changing the kernel
# default (currently '0').
-ALIGN=1
+ALIGN=3
. /etc/default/rcS
test -e /proc/cpu/alignment -a -n "$ALIGN" -a "$ALIGN" -ge 0 -a "$ALIGN" -lt 6 &&
echo "$ALIGN" >/proc/cpu/alignment
diff --git a/packages/initscripts/initscripts-1.0/slugos/bootclean.sh b/packages/initscripts/initscripts-1.0/slugos/bootclean.sh
index 1304cb3794..3b17d6d617 100644
--- a/packages/initscripts/initscripts-1.0/slugos/bootclean.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/bootclean.sh
@@ -16,8 +16,8 @@
if [ -d /tmp -a ! -L /tmp ] ; then
echo "bootclean.sh: Cleaning /tmp..."
cd /tmp || { echo "bootclean.sh: unable to cd to /tmp." ; return 1 ; }
- find . -depth -xdev ! -type d -print0 | xargs -0r rm -f --
- find . -depth -xdev -type d ! -name . -empty -exec rmdir \{\} \;
+ find . -xdev ! -type d -print0 | xargs -0r rm -f --
+ find . -depth -xdev -type d ! -name . -exec rmdir \{\} \;
else
echo "bootclean.sh: Skipping /tmp (not a directory)..."
fi
diff --git a/packages/initscripts/initscripts-slugos_1.0.bb b/packages/initscripts/initscripts-slugos_1.0.bb
index 0608db714d..242a55ad7a 100644
--- a/packages/initscripts/initscripts-slugos_1.0.bb
+++ b/packages/initscripts/initscripts-slugos_1.0.bb
@@ -10,7 +10,7 @@ RCONFLICTS = "initscripts"
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.12"
+PR := "${PR}.13"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"