aboutsummaryrefslogtreecommitdiffstats
path: root/packages/initscripts
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-08-31 23:43:07 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2006-08-31 23:43:07 +0000
commit595bc05e18f8dc76aa07f6a59349fa7180885fd5 (patch)
tree86a435acd488bcac5bc5c347a6500dd14fae3315 /packages/initscripts
parent2499a6a0c904d96d20ef9c416f1a35ff2b1ab79a (diff)
downloadopenembedded-595bc05e18f8dc76aa07f6a59349fa7180885fd5.tar.gz
initscripts-slugos: Fix extra symlinks that break do_install. Bump PR of initscripts
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-slugos_1.0.bb17
-rw-r--r--packages/initscripts/initscripts_1.0.bb2
2 files changed, 13 insertions, 6 deletions
diff --git a/packages/initscripts/initscripts-slugos_1.0.bb b/packages/initscripts/initscripts-slugos_1.0.bb
index dcb57e92bb..f64e11dfe4 100644
--- a/packages/initscripts/initscripts-slugos_1.0.bb
+++ b/packages/initscripts/initscripts-slugos_1.0.bb
@@ -4,14 +4,14 @@
# problems in the initscripts on SlugOS. The problems
# mostly come down to the order the scripts are executed
# in.
-require initscripts_${PV}.bb
+include initscripts_${PV}.bb
MAINTAINER = "John Bowler <jbowler@acm.org>"
RCONFLICTS = "initscripts"
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.9"
+PR := "${PR}.10"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
@@ -64,15 +64,20 @@ do_install_append() {
# udev will run at S04 if installed
rm ${D}${sysconfdir}/rcS.d/S03sysfs
rm ${D}${sysconfdir}/rcS.d/S38devpts.sh
-# rm ${D}${sysconfdir}/rcS.d/S06alignment
+ rm ${D}${sysconfdir}/rcS.d/S06alignment
+ rm ${D}${sysconfdir}/rcS.d/S37populate-volatile.sh
+ rm ${D}${sysconfdir}/rc0.d/S25save-rtc.sh
+ rm ${D}${sysconfdir}/rc6.d/S25save-rtc.sh
+
+
# Check the result
find ${D}${sysconfdir}/rc?.d ! -type d -print | {
status=0
while read d
do
- oenote "initscripts-slugos: unexpected link $f"
- status = 1
+ oenote "initscripts-slugos: unexpected link $d"
+ status=1
done
test $status -eq 0 ||
oefatal "initscripts-slugos: new links break do_install"
@@ -102,6 +107,7 @@ do_install_append() {
# base-files populate-volatile.sh runs at S37
update-rc.d -r ${D} devpts.sh start 38 S .
# slugos file syslog starts here (39)
+ update-rc.d -r ${D} populate-volatile.sh start 37 S .
# set hostname and domainname before the network script works (by
# entering them at level 40), networking may reset them.
@@ -138,6 +144,7 @@ do_install_append() {
# This is the special, correct, slugos umountnfs.sh (it looks in
# the /proc/mounts information, not /etc/fstab)
update-rc.d -r ${D} umountnfs.sh start 31 0 6 .
+ update-rc.d -r ${D} save-rtc.sh start 25 0 6 .
# portmap stops at 32
# slugos network syslog stops here (39)
# networking stops at 40 (nothing else does, believe me.)
diff --git a/packages/initscripts/initscripts_1.0.bb b/packages/initscripts/initscripts_1.0.bb
index 29747d41c2..9cf7e47de0 100644
--- a/packages/initscripts/initscripts_1.0.bb
+++ b/packages/initscripts/initscripts_1.0.bb
@@ -92,7 +92,7 @@ do_install () {
# Install device dependent scripts
#
- if [ "${DISTRO}" == "openzaurus" ]; then
+ if [ "${DISTRO}" = "openzaurus" ]; then
cat ${WORKDIR}/checkversion | sed -e "s,VERSION,${KERNEL_VERSION}-${DISTRO_VERSION}," > ${D}${sysconfdir}/init.d/checkversion
chmod 0755 ${D}${sysconfdir}/init.d/checkversion
ln -sf ../init.d/checkversion ${D}${sysconfdir}/rcS.d/S01version