aboutsummaryrefslogtreecommitdiffstats
path: root/packages/initscripts
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-02-06 06:25:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 06:25:25 +0000
commitf9fd6571b2567f132672b118d2826c1a83955c02 (patch)
treefa5693a819e9a6edf8c28464880fc0e471066219 /packages/initscripts
parenta56f5680381313b9a12a3ba133c5cb7a2154aa67 (diff)
downloadopenembedded-f9fd6571b2567f132672b118d2826c1a83955c02.tar.gz
initscripts-slugos: make checkroot.sh work with any sulogin in 1.0
Diffstat (limited to 'packages/initscripts')
-rw-r--r--packages/initscripts/initscripts-1.0/slugos/checkroot.sh16
-rw-r--r--packages/initscripts/initscripts-slugos_1.0.bb2
2 files changed, 5 insertions, 13 deletions
diff --git a/packages/initscripts/initscripts-1.0/slugos/checkroot.sh b/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
index c70855ee43..be640fd254 100644
--- a/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
+++ b/packages/initscripts/initscripts-1.0/slugos/checkroot.sh
@@ -130,22 +130,14 @@ else
echo "CONTROL-D will exit from this shell and REBOOT the system."
echo
leds system panic
- beep -r 5
+ leds beep -r 5
# Start a single user shell on the console
if single_user_ok
then
- sulogin -t 600 $CONSOLE
- # if this exits with SIGALRM (which happens to be 142) the
- # timeout happened, do not, then, reboot!
- if test $? -ne 142
- then
- reboot -f
- else
- echo "/etc/init.d/checkroot.sh: sulogin timeout, continuing boot"
- fi
- else
- echo "/etc/init.d/checkroot.sh: fsck failed, continuing boot"
+ sulogin -t 300 $CONSOLE
+ # assume the system is ok now...
fi
+ echo "... continuing boot"
fi
else
echo "*** ERROR! Cannot fsck root fs because it is not mounted read-only!"
diff --git a/packages/initscripts/initscripts-slugos_1.0.bb b/packages/initscripts/initscripts-slugos_1.0.bb
index df89fd161b..7a4f79c20b 100644
--- a/packages/initscripts/initscripts-slugos_1.0.bb
+++ b/packages/initscripts/initscripts-slugos_1.0.bb
@@ -11,7 +11,7 @@ RCONFLICTS = "initscripts"
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.8"
+PR := "${PR}.9"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"