aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg-utils
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-06-30 07:57:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-30 07:57:45 +0000
commit9a83e6e9de1e231a0e5afd8d6b21c924cbc8889f (patch)
treee27158c3497d377ed290993d9c62ec73251339e6 /packages/ipkg-utils
parent19460a737d7398b58f1e7c1b8e75828167b61007 (diff)
downloadopenembedded-9a83e6e9de1e231a0e5afd8d6b21c924cbc8889f.tar.gz
ipkg-utils-native: add patch to stop ipkg-make-index move all ipkg to morgue/
Diffstat (limited to 'packages/ipkg-utils')
-rw-r--r--packages/ipkg-utils/ipkg-utils-native/.mtn2git_empty0
-rw-r--r--packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch17
-rw-r--r--packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb3
3 files changed, 19 insertions, 1 deletions
diff --git a/packages/ipkg-utils/ipkg-utils-native/.mtn2git_empty b/packages/ipkg-utils/ipkg-utils-native/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ipkg-utils/ipkg-utils-native/.mtn2git_empty
diff --git a/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch b/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch
new file mode 100644
index 0000000000..a9e6fc4d05
--- /dev/null
+++ b/packages/ipkg-utils/ipkg-utils-native/ipkg-utils-fix.patch
@@ -0,0 +1,17 @@
+--- ../../../work/i686-linux/ipkg-utils-native-1.6+cvs20050404-r6/ipkg-utils/ipkg.py 2005-01-08 19:08:52.000000000 +0100
++++ ipkg-utils/ipkg.py 2006-06-29 12:52:58.466446000 +0200
+@@ -150,11 +150,11 @@
+ stat = os.stat(fn)
+ self.size = stat[ST_SIZE]
+ self.filename = os.path.basename(fn)
+- ## sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
++ sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
+ if self.isdeb:
+- control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - '*control'","r")
++ control = os.popen("ar p "+fn+" control.tar.gz | tar xfzO - './control'","r")
+ else:
+- control = os.popen("tar xfzO "+fn+" '*control.tar.gz' | tar xfzO - '*control'","r")
++ control = os.popen("tar xfzO "+fn+" 'control.tar.gz' | tar xfzO - './control'","r")
+ line = control.readline()
+ while 1:
+ if not line: break
diff --git a/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb b/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
index eb11ac560d..ab8f4d63e0 100644
--- a/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
+++ b/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
@@ -1,7 +1,8 @@
include ipkg-utils_${PV}.bb
+SRC_URI += "file://ipkg-utils-fix.patch;patch=1"
RDEPENDS = ""
-PR = "r6"
+PR = "r7"
inherit native