aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-12-02 17:51:14 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-12-02 17:51:14 +0000
commit07ca58604ba30f72ca2adf7657f7c78a1d25cd9c (patch)
tree7a174b6ee78f3bff7cab82b5f5740e9902b610ed /packages/ipkg
parent282088f1ad999b8427ad8acf43021538388afa60 (diff)
parent5e6ff63a6a2d9f26b104ea604c934d996a28d71e (diff)
downloadopenembedded-07ca58604ba30f72ca2adf7657f7c78a1d25cd9c.tar.gz
merge of '48e3d8ce0c21c80e6e929a3a992826251eed2f4d'
and 'd3dfa43eb653664a9ed9a5ae97b24949fee1c9cf'
Diffstat (limited to 'packages/ipkg')
-rw-r--r--packages/ipkg/files/ipkg-configure5
-rw-r--r--packages/ipkg/ipkg.inc21
-rw-r--r--packages/ipkg/ipkg_0.99.163.bb3
3 files changed, 18 insertions, 11 deletions
diff --git a/packages/ipkg/files/ipkg-configure b/packages/ipkg/files/ipkg-configure
new file mode 100644
index 0000000000..e0c65ad4e2
--- /dev/null
+++ b/packages/ipkg/files/ipkg-configure
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+echo "Starting to configure packages..."
+ipkg-cl configure
+echo "Finished to configure packages."
diff --git a/packages/ipkg/ipkg.inc b/packages/ipkg/ipkg.inc
index b1e2f19267..9154572f08 100644
--- a/packages/ipkg/ipkg.inc
+++ b/packages/ipkg/ipkg.inc
@@ -10,28 +10,24 @@ FILES_libipkg = "${libdir}/*.so.*"
AUTO_LIBNAME_PKGS = "libipkg"
SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://ipkg-configure \
file://terse.patch;patch=1"
S = "${WORKDIR}/ipkg/C"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-rc.d
# Define a variable to allow distros to run configure earlier.
# (for example, to enable loading of ethernet kernel modules before networking starts)
IPKG_INIT_POSITION = "98"
IPKG_INIT_POSITION_slugos = "41"
+INITSCRIPT_NAME = "ipkg-configure"
+INITSCRIPT_PARAMS = "start ${IPKG_INIT_POSITION} S ."
+
+
pkg_postinst_ipkg () {
#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-ipkg-cl configure
-" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
- chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
-fi
-
update-alternatives --install ${bindir}/ipkg ipkg ${bindir}/ipkg-cl 100
}
@@ -40,6 +36,11 @@ pkg_postrm_ipkg () {
update-alternatives --remove ipkg ${bindir}/ipkg-cl
}
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+}
+
do_stage() {
oe_libinstall -so libipkg ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/replace/
diff --git a/packages/ipkg/ipkg_0.99.163.bb b/packages/ipkg/ipkg_0.99.163.bb
index 56e25900c1..fccfe8d53f 100644
--- a/packages/ipkg/ipkg_0.99.163.bb
+++ b/packages/ipkg/ipkg_0.99.163.bb
@@ -1,9 +1,10 @@
include ipkg.inc
-PR = "r5"
+PR = "r6"
S = "${WORKDIR}/ipkg-${PV}"
SRC_URI = "http://www.handhelds.org/pub/packages/ipkg/ipkg-${PV}.tar.gz \
+ file://ipkg-configure \
file://terse.patch;patch=1 \
file://is-processing.patch;patch=1 \
file://1-pkg-parse--Optimize-inefficient-parsing.patch;patch=1 \