aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-04-28 22:26:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-28 22:26:06 +0000
commit713aeebd14816802f983dd52a03da51dd014c194 (patch)
tree75c1308ecd1a5df7d2f56aaa507a90280d7b016f /packages/ipkg
parenta7b022857cab7908fd7358785c2f87e48b1b0039 (diff)
downloadopenembedded-713aeebd14816802f983dd52a03da51dd014c194.tar.gz
ipkg: Added an IPKG_INIT_ORDER variable (defaulting to 98) to allow distros to change the order of S98configure (e.g. to put it before S40networking so that ethernet kernel modules can be configured before networking needs them).
Diffstat (limited to 'packages/ipkg')
-rw-r--r--packages/ipkg/ipkg.inc9
-rw-r--r--packages/ipkg/ipkg_0.99.154.bb2
2 files changed, 8 insertions, 3 deletions
diff --git a/packages/ipkg/ipkg.inc b/packages/ipkg/ipkg.inc
index f535cfbef0..8fc6c9efe0 100644
--- a/packages/ipkg/ipkg.inc
+++ b/packages/ipkg/ipkg.inc
@@ -16,6 +16,11 @@ S = "${WORKDIR}/ipkg/C"
inherit autotools pkgconfig
+# Define a variable to allow distros to run configure earlier.
+# (for example, to enable loading of ethernet kernel modules before networking starts)
+IPKG_INIT_POSITION = "98"
+IPKG_INIT_POSITION_slugos = "41"
+
pkg_postinst_ipkg () {
#!/bin/sh
if [ "x$D" != "x" ]; then
@@ -23,8 +28,8 @@ if [ "x$D" != "x" ]; then
# this happens at S98 where our good 'ole packages script used to run
echo -e "#!/bin/sh
ipkg-cl configure
-" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
- chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
+" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
+ chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure
fi
update-alternatives --install ${bindir}/ipkg ipkg ${bindir}/ipkg-cl 100
diff --git a/packages/ipkg/ipkg_0.99.154.bb b/packages/ipkg/ipkg_0.99.154.bb
index 9285c61819..de6af147b6 100644
--- a/packages/ipkg/ipkg_0.99.154.bb
+++ b/packages/ipkg/ipkg_0.99.154.bb
@@ -1,2 +1,2 @@
include ipkg.inc
-PR = "r2"
+PR = "r3"