aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipkg
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-12-01 22:51:35 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-12-01 22:51:35 +0000
commitb92188969f5533d36b6d5d6c775d95006e29af56 (patch)
treed1c081c34e49b99229d8e5da681a9c6b87b2b8d3 /packages/ipkg
parent8f78631b6469ae23f780ae7b71311b90ff070d91 (diff)
downloadopenembedded-b92188969f5533d36b6d5d6c775d95006e29af56.tar.gz
ipkg-native: Fix the infamous ' cannot create /usr/lib/ipkg' warning (from poky)
Diffstat (limited to 'packages/ipkg')
-rw-r--r--packages/ipkg/files/ipkg_bugfix.patch44
-rw-r--r--packages/ipkg/ipkg-native_0.99.163.bb3
2 files changed, 46 insertions, 1 deletions
diff --git a/packages/ipkg/files/ipkg_bugfix.patch b/packages/ipkg/files/ipkg_bugfix.patch
new file mode 100644
index 0000000000..51eccbb2bd
--- /dev/null
+++ b/packages/ipkg/files/ipkg_bugfix.patch
@@ -0,0 +1,44 @@
+Index: C/ipkg_conf.c
+===================================================================
+--- C.orig/ipkg_conf.c 2005-06-21 13:59:32.000000000 +0000
++++ C/ipkg_conf.c 2007-11-27 01:11:17.000000000 +0000
+@@ -423,6 +423,7 @@
+ nv_pair_t *nv_pair;
+ pkg_dest_t *dest;
+ char *root_dir;
++ char *list_dir2;
+
+ for (iter = nv_pair_list->head; iter; iter = iter->next) {
+ nv_pair = iter->data;
+@@ -432,8 +433,14 @@
+ } else {
+ root_dir = strdup(nv_pair->value);
+ }
+- dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, lists_dir);
++ if (conf->offline_root) {
++ sprintf_alloc(&list_dir2, "%s%s", conf->offline_root, lists_dir);
++ } else {
++ list_dir2 = strdup(lists_dir);
++ }
++ dest = pkg_dest_list_append(&conf->pkg_dest_list, nv_pair->name, root_dir, list_dir2);
+ free(root_dir);
++ free(list_dir2);
+ if (dest == NULL) {
+ continue;
+ }
+@@ -562,13 +569,13 @@
+ } else if (strcmp(type, "dest") == 0) {
+ nv_pair_list_append(tmp_dest_nv_pair_list, name, value);
+ } else if (strcmp(type, "lists_dir") == 0) {
+- *lists_dir = realloc(*lists_dir,strlen(value)+1);
++ *lists_dir = realloc(*lists_dir,strlen(name)+1);
+ if (*lists_dir == NULL) {
+ ipkg_message(conf, IPKG_ERROR, "ERROR: Not enough memory\n");
+ free(options);
+ return EINVAL;
+ }
+- sprintf (*lists_dir,"%s",value);
++ sprintf (*lists_dir,"%s", name);
+ } else if (strcmp(type, "arch") == 0) {
+ ipkg_message(conf, IPKG_INFO, "supported arch %s priority (%s)\n", name, value);
+ if (!value) {
diff --git a/packages/ipkg/ipkg-native_0.99.163.bb b/packages/ipkg/ipkg-native_0.99.163.bb
index 13609c9037..c8e7d08588 100644
--- a/packages/ipkg/ipkg-native_0.99.163.bb
+++ b/packages/ipkg/ipkg-native_0.99.163.bb
@@ -2,7 +2,7 @@ S = "${WORKDIR}/ipkg-${PV}"
#require ipkg_${PV}.bb
require ipkg-native.inc
-PR = "r2"
+PR = "r3"
inherit autotools pkgconfig native
@@ -10,5 +10,6 @@ SRC_URI = "http://www.handhelds.org/pub/packages/ipkg/ipkg-${PV}.tar.gz \
file://is-processing.patch;patch=1 \
file://1-pkg-parse--Optimize-inefficient-parsing.patch;patch=1 \
file://2-pkg-vec--Optimize-gross-inefficiency.patch;patch=1 \
+ file://ipkg_bugfix.patch;patch=1 \
"