aboutsummaryrefslogtreecommitdiffstats
path: root/packages/iproute2/iproute2.inc
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-03-17 05:42:27 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-03-17 05:42:27 +0000
commit9664a6cc3405978514cf1f6e7a3331e5ba0171a9 (patch)
tree7cb05caf3c20986d94bb6909fd7b636bac578936 /packages/iproute2/iproute2.inc
parent7a434cc8d2c1455a79dc94f3e934ed3736bb1aa1 (diff)
downloadopenembedded-9664a6cc3405978514cf1f6e7a3331e5ba0171a9.tar.gz
iproute2: Add 2.6.20 to pick up a lot of new commands and bug fixes.
Diffstat (limited to 'packages/iproute2/iproute2.inc')
-rw-r--r--packages/iproute2/iproute2.inc14
1 files changed, 11 insertions, 3 deletions
diff --git a/packages/iproute2/iproute2.inc b/packages/iproute2/iproute2.inc
index 006b27b60f..e14bfdeefe 100644
--- a/packages/iproute2/iproute2.inc
+++ b/packages/iproute2/iproute2.inc
@@ -3,12 +3,20 @@ SECTION = "base"
LICENSE = "GPL"
DEPENDS = "flex-native bison-native"
-# Set DATE in the .bb file
+# This changed from iproute2 to iproute with version 2.6.20, so set to
+# iproute in the recipe for 2.6.20 and newer versions.
+DIRNAME ?= "${PN}"
+
+# Set the DATE in the .bb file
SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${DATE}.tar.gz"
-S = "${WORKDIR}/${P}-${DATE}"
+S = "${WORKDIR}/${DIRNAME}-${PV}-${DATE}"
-EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin"
+EXTRA_OEMAKE = "CC='${CC}' \
+ KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include \
+ DOCDIR=${docdir}/iproute2 \
+ SUBDIRS='lib tc ip' \
+ SBINDIR=/sbin"
do_install () {
oe_runmake DESTDIR=${D} install