aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipsec-tools
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-10-13 00:50:28 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-10-13 00:50:28 +0000
commit0a322d4e304f76093842f9c3d8d28eed5715329b (patch)
tree068801e0ff533cb1cc2c4e2f36395c1e4fb422cd /packages/ipsec-tools
parentdfc17e4d30a3819391773e217161fe3e930510ea (diff)
downloadopenembedded-0a322d4e304f76093842f9c3d8d28eed5715329b.tar.gz
ipsec-tools 0.6.6: Add version 0.6.6 which builds with glibc 2.4,
fixes lots of bugs and adds lots of additional functionality.
Diffstat (limited to 'packages/ipsec-tools')
-rw-r--r--packages/ipsec-tools/ipsec-tools-0.6.6/.mtn2git_empty0
-rw-r--r--packages/ipsec-tools/ipsec-tools-0.6.6/racoon-search-missing.patch17
-rw-r--r--packages/ipsec-tools/ipsec-tools_0.6.6.bb48
3 files changed, 65 insertions, 0 deletions
diff --git a/packages/ipsec-tools/ipsec-tools-0.6.6/.mtn2git_empty b/packages/ipsec-tools/ipsec-tools-0.6.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ipsec-tools/ipsec-tools-0.6.6/.mtn2git_empty
diff --git a/packages/ipsec-tools/ipsec-tools-0.6.6/racoon-search-missing.patch b/packages/ipsec-tools/ipsec-tools-0.6.6/racoon-search-missing.patch
new file mode 100644
index 0000000000..eebcb87017
--- /dev/null
+++ b/packages/ipsec-tools/ipsec-tools-0.6.6/racoon-search-missing.patch
@@ -0,0 +1,17 @@
+Older versions of openssl don't provide all the required crypto code.
+To handle this case ipsec-tools includes it's own version of the
+required crypto code but it fails to add it the search path so
+compilation fails. Fix it here since OE currently have an older
+version of openssl.
+
+--- ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:10:57 1.1
++++ ipsec-tools-0.6.6/src/racoon/Makefile.am 2006/08/17 05:12:08
+@@ -9,7 +9,7 @@
+
+ adminsockdir=${localstatedir}/racoon
+
+-INCLUDES = -I${srcdir}/../libipsec
++INCLUDES = -I${srcdir}/../libipsec -I${srcdir}/missing
+ AM_CFLAGS = -D_GNU_SOURCE @GLIBC_BUGS@ -DSYSCONFDIR=\"${sysconfdir}\" \
+ -DADMINPORTDIR=\"${adminsockdir}\"
+ AM_LDFLAGS = @EXTRA_CRYPTO@ -lcrypto
diff --git a/packages/ipsec-tools/ipsec-tools_0.6.6.bb b/packages/ipsec-tools/ipsec-tools_0.6.6.bb
new file mode 100644
index 0000000000..0e2a82e370
--- /dev/null
+++ b/packages/ipsec-tools/ipsec-tools_0.6.6.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \
+Linux-2.6 IPsec implementation."
+HOMEPAGE = "http://ipsec-tools.sourceforge.net/"
+SECTION = "console/net"
+LICENSE = "BSD"
+DEPENDS = "virtual/kernel openssl readline flex"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${PV}.tar.bz2 \
+ file://racoon-search-missing.patch;patch=1"
+
+inherit autotools
+
+# Options:
+# --enable-adminport enable admin port
+# --enable-rc5 enable RC5 encryption (patented)
+# --enable-idea enable IDEA encryption (patented)
+# --enable-gssapi enable GSS-API authentication
+# --enable-hybrid enable hybrid, both mode-cfg and xauth support
+# --enable-frag enable IKE fragmentation payload support
+# --enable-stats enable statistics logging function
+# --enable-dpd enable dead peer detection
+# --enable-samode-unspec enable to use unspecified a mode of SA
+# --disable-ipv6 disable ipv6 support
+# --enable-natt enable NAT-Traversal (yes/no/kernel)
+# --enable-natt-versions=list list of supported NAT-T versions delimited by coma.
+# --with-kernel-headers=/lib/modules/<uname>/build/include
+# where your Linux Kernel headers are installed
+# --with-readline support readline input (yes by default)
+# --with-flex use directiory (default: no)
+# --with-flexlib=<LIB> specify flex library.
+# --with-openssl=DIR specify OpenSSL directory
+# --with-libradius=DIR specify libradius path (like/usr/pkg)
+# --with-libpam=DIR specify libpam path (like/usr/pkg)
+#
+# Note: if you give it the actual kernel headers it won't build, it actually
+# needs to point at the linux-libc-headers version of the kernel headers.
+#
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_INCDIR} \
+ --with-readline \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+ --without-libradius \
+ --without-gssapi \
+ --without-libpam"
+
+# Sometimes it attempts to use y.tab.c before it is generated. Note
+# that the failure case is very rare, but it does happen.
+PARALLEL_MAKE = ""