aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ipsec-tools
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/ipsec-tools
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/ipsec-tools')
-rw-r--r--packages/ipsec-tools/.mtn2git_empty0
-rw-r--r--packages/ipsec-tools/files/.mtn2git_empty0
-rw-r--r--packages/ipsec-tools/files/cross.patch75
-rw-r--r--packages/ipsec-tools/ipsec-tools.inc30
-rw-r--r--packages/ipsec-tools/ipsec-tools_0.4+0.5-rc1.bb6
-rw-r--r--packages/ipsec-tools/ipsec-tools_0.4+0.5-rc2.bb6
6 files changed, 117 insertions, 0 deletions
diff --git a/packages/ipsec-tools/.mtn2git_empty b/packages/ipsec-tools/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ipsec-tools/.mtn2git_empty
diff --git a/packages/ipsec-tools/files/.mtn2git_empty b/packages/ipsec-tools/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ipsec-tools/files/.mtn2git_empty
diff --git a/packages/ipsec-tools/files/cross.patch b/packages/ipsec-tools/files/cross.patch
index e69de29bb2..a0e7b1da27 100644
--- a/packages/ipsec-tools/files/cross.patch
+++ b/packages/ipsec-tools/files/cross.patch
@@ -0,0 +1,75 @@
+Index: ipsec-tools-0.5-rc1/acracoon.m4
+===================================================================
+--- ipsec-tools-0.5-rc1.orig/acracoon.m4 2004-09-21 10:35:23.000000000 -0400
++++ ipsec-tools-0.5-rc1/acracoon.m4 2005-02-03 13:56:02.144689256 -0500
+@@ -92,6 +92,8 @@
+
+ AC_DEFUN([RACOON_CHECK_BUGGY_GETADDRINFO], [
+ AC_MSG_CHECKING(getaddrinfo bug)
++ AC_CACHE_CHECK([for a buggy getaddrinfo],
++ racoon_cv_bug_getaddrinfo,[
+ saved_CFLAGS=$CFLAGS
+ CFLAGS="-Wall -O2"
+ AC_TRY_RUN([
+@@ -182,12 +184,10 @@
+ exit(1);
+ }
+ ],
+- AC_MSG_RESULT(good)
+- buggygetaddrinfo=no,
+- AC_MSG_RESULT(buggy)
+- buggygetaddrinfo=yes,
+- AC_MSG_RESULT(buggy)
+- buggygetaddrinfo=yes)
++ racoon_cv_bug_getaddrinfo=no,
++ racoon_cv_bug_getaddrinfo=yes,
++ racoon_cv_bug_getaddrinfo=yes)
+ CFLAGS=$saved_CFLAGS
+ unset saved_CFLAGS
++ ])
+ ])
+Index: ipsec-tools-0.5-rc1/configure.ac
+===================================================================
+--- ipsec-tools-0.5-rc1.orig/configure.ac 2005-01-04 09:20:57.000000000 -0500
++++ ipsec-tools-0.5-rc1/configure.ac 2005-02-03 14:02:34.935975904 -0500
+@@ -16,6 +16,9 @@
+ AC_PROG_LIBTOOL
+ AC_PROG_YACC
+ AM_PROG_LEX
++ac_save_LIBS="$LIBS"
++AC_CHECK_LIB(fl, yywrap, LEXLIB="-lfl")
++LIBS="$ac_save_LIBS"
+ AC_SUBST(LEXLIB)
+ AC_PROG_EGREP
+
+@@ -57,10 +60,12 @@
+ AC_SUBST(CONFIGURE_AMFLAGS) ],
+ [ KERNEL_INCLUDE="/lib/modules/`uname -r`/build/include" ])
+
++ if test "$cross_compiling" = no; then
+ AC_CHECK_FILE($KERNEL_INCLUDE/linux/pfkeyv2.h, ,
+ [ AC_CHECK_FILE(/usr/src/linux/include/linux/pfkeyv2.h,
+ KERNEL_INCLUDE=/usr/src/linux/include ,
+ [ AC_MSG_ERROR([Unable to find linux-2.6 kernel headers. Aborting.]) ] ) ] )
++ fi
+ AC_SUBST(KERNEL_INCLUDE)
+ # We need the configure script to run with correct kernel headers.
+ # However we don't want to point to kernel source tree in compile time,
+@@ -176,7 +181,7 @@
+ AC_MSG_CHECKING(sha2 support)
+ AC_DEFINE([WITH_SHA2], [], [SHA2 support])
+ AC_CHECK_HEADER(openssl/sha2.h, [], [
+- CPPFLAGS_ADD="$CPPFLAGS_ADD -I./\${top_srcdir}/src/racoon/missing"
++ CPPFLAGS_ADD="$CPPFLAGS_ADD -I\${top_srcdir}/src/racoon/missing"
+ AC_LIBOBJ([sha2])
+ CRYPTOBJS="$CRYPTOBJS sha2.o"])
+ AC_SUBST(CRYPTOBJS)
+@@ -339,7 +344,7 @@
+ fi
+
+ RACOON_CHECK_BUGGY_GETADDRINFO
+-if test "$buggygetaddrinfo" = "yes"; then
++if test "$racoon_cv_bug_getaddrinfo" = "yes"; then
+ AC_MSG_ERROR([Broken getaddrinfo() is no longer supported. Aborting.])
+ fi
+
diff --git a/packages/ipsec-tools/ipsec-tools.inc b/packages/ipsec-tools/ipsec-tools.inc
index e69de29bb2..2b1669f987 100644
--- a/packages/ipsec-tools/ipsec-tools.inc
+++ b/packages/ipsec-tools/ipsec-tools.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "IPsec-Tools is a port of KAME's IPsec utilities to the \
+Linux-2.6 IPsec implementation."
+DEPENDS = "virtual/kernel openssl readline flex"
+LICENSE = "BSD"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SECTION = "console/net"
+
+inherit autotools
+
+# --enable-adminport enable admin port
+# --enable-gssapi enable GSS-API authentication
+# --enable-hybrid enable hybrid, both mode-cfg and xauth support
+# --enable-frag enable IKE fragmentation payload support
+# --enable-stats enable statistics logging function
+# --enable-dpd enable dead peer detection
+# --enable-samode-unspec enable to use unspecified a mode of SA
+# --disable-ipv6 disable ipv6 support
+# --enable-natt enable NAT-Traversal (yes/no/kernel)
+#
+# --with-kernel-headers=/lib/modules/<uname>/build/include
+# where your Linux Kernel headers are installed
+# --with-readline support readline input (yes by default)
+# --with-openssl=DIR specify OpenSSL directory
+# --with-libradius=DIR specify libradius path (like/usr/pkg)
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_KERNEL_DIR} \
+ --with-readline \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+ --without-libradius \
+ --without-gssapi"
+PARALLEL_MAKE = ""
diff --git a/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc1.bb b/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc1.bb
index e69de29bb2..f14f7a0bb0 100644
--- a/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc1.bb
+++ b/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc1.bb
@@ -0,0 +1,6 @@
+include ipsec-tools.inc
+
+BV = "${@bb.data.getVar('PV', d, 1).split('+')[1]}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${BV}.tar.bz2 \
+ file://cross.patch;patch=1"
+S = "${WORKDIR}/ipsec-tools-${BV}"
diff --git a/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc2.bb b/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc2.bb
index e69de29bb2..dc52b5f230 100644
--- a/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc2.bb
+++ b/packages/ipsec-tools/ipsec-tools_0.4+0.5-rc2.bb
@@ -0,0 +1,6 @@
+include ipsec-tools.inc
+
+BV = "${@bb.data.getVar('PV', d, 1).split('+')[1].replace('-','')}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ipsec-tools/ipsec-tools-${BV}.tar.bz2 \
+ file://cross.patch;patch=1"
+S = "${WORKDIR}/ipsec-tools-${BV}"