aboutsummaryrefslogtreecommitdiffstats
path: root/packages/irda-utils
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-02-09 19:00:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-09 19:00:50 +0000
commitda1676aa007bd113667247b1b5530d1be858507c (patch)
treeed566445b53366451f21c097dfdb91a91205191e /packages/irda-utils
parentb384d1778ec171faeeec537020c8f8a30107ea95 (diff)
downloadopenembedded-da1676aa007bd113667247b1b5530d1be858507c.tar.gz
irda-utils 0.9.16: write out /etc/sysconfig/irda in the init script, rather
than in postinst.
Diffstat (limited to 'packages/irda-utils')
-rwxr-xr-xpackages/irda-utils/files/init30
-rw-r--r--packages/irda-utils/irda-utils_0.9.16.bb35
2 files changed, 30 insertions, 35 deletions
diff --git a/packages/irda-utils/files/init b/packages/irda-utils/files/init
index f1594aae87..e7163d3ad3 100755
--- a/packages/irda-utils/files/init
+++ b/packages/irda-utils/files/init
@@ -1,6 +1,34 @@
#! /bin/sh
-# Source IrDA networking configuration.
+module_id() {
+ awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+}
+
+if [ ! -f /etc/sysconfig/irda ]; then
+
+ case `module_id` in
+ "HP iPAQ H2200" | "HP iPAQ HX4700")
+ IRDA=yes
+ DEVICE=/dev/tts/2
+ DONGLE=
+ DISCOVERY=
+ ;;
+ *)
+ IRDA=yes
+ DEVICE=/dev/ttyS1
+ DONGLE=
+ DISCOVERY=
+ ;;
+ esac
+
+ echo "IRDA=$IRDA" > /etc/sysconfig/irda
+ if [ $IRDA = "yes" ]; then
+ echo "DEVICE=$DEVICE" >> /etc/sysconfig/irda
+ echo "DONGLE=$DONGLE" >> /etc/sysconfig/irda
+ echo "DISCOVERY=$DISCOVERY" >> /etc/sysconfig/irda
+ fi
+fi
+
. /etc/sysconfig/irda
# Check that irda is up.
diff --git a/packages/irda-utils/irda-utils_0.9.16.bb b/packages/irda-utils/irda-utils_0.9.16.bb
index 4acfeff04d..1753edca88 100644
--- a/packages/irda-utils/irda-utils_0.9.16.bb
+++ b/packages/irda-utils/irda-utils_0.9.16.bb
@@ -3,7 +3,7 @@ IrDA allows communication over Infrared with other devices \
such as phones and laptops."
SECTION = "base"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
file://configure.patch;patch=1 \
@@ -30,36 +30,3 @@ do_install () {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/irattach
}
-
-pkg_postinst () {
-#!/bin/sh
-
-module_id() {
- awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
- }
-
-if [ ! -f /etc/sysconfig/irda ]; then
-
- case `module_id` in
- "HP iPAQ H2200" | "HP iPAQ HX4700")
- IRDA=yes
- DEVICE=/dev/tts/2
- DONGLE=
- DISCOVERY=
- ;;
- *)
- IRDA=yes
- DEVICE=/dev/ttyS1
- DONGLE=
- DISCOVERY=
- ;;
- esac
-
- echo "IRDA=$IRDA" > /etc/sysconfig/irda
- if [ $IRDA = "yes" ]; then
- echo "DEVICE=$DEVICE" >> /etc/sysconfig/irda
- echo "DONGLE=$DONGLE" >> /etc/sysconfig/irda
- echo "DISCOVERY=$DISCOVERY" >> /etc/sysconfig/irda
- fi
-fi
-}