aboutsummaryrefslogtreecommitdiffstats
path: root/packages/irk
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-01-25 21:10:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-25 21:10:55 +0000
commit6d234a0fb1475411c933abf2b1ffea702f89dcd0 (patch)
tree0e9556914f95d6981048a2684df22b5e5e141d71 /packages/irk
parentef801f025a2ef264b4373003ba410a47d48cffb3 (diff)
downloadopenembedded-6d234a0fb1475411c933abf2b1ffea702f89dcd0.tar.gz
irk: cleaned build of it
- moved common code to irk.inc - irk renamed to irk-targus (as it handle Pocketop and Targus keyboard) - irk-targus and irk-belkin both conflicts/replaces each other
Diffstat (limited to 'packages/irk')
-rw-r--r--packages/irk/irk-belkin_0.11.bb34
-rw-r--r--packages/irk/irk-targus_0.11.0.bb10
-rw-r--r--packages/irk/irk.inc (renamed from packages/irk/irk_0.11.bb)17
3 files changed, 21 insertions, 40 deletions
diff --git a/packages/irk/irk-belkin_0.11.bb b/packages/irk/irk-belkin_0.11.bb
index a8d6056914..9710e71109 100644
--- a/packages/irk/irk-belkin_0.11.bb
+++ b/packages/irk/irk-belkin_0.11.bb
@@ -1,31 +1,9 @@
-DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus. (version with Belkin support instead of Targus)"
-SECTION = "opie/inputmethods"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-LICENSE = "GPL"
-DEPENDS = "virtual/libqpe lirc"
-RDEPENDS = "lirc"
-RPROVIDES = "irk"
-RCONFLICTS = "irk"
-RREPLACES = "irk"
-PR = "r1"
+include irk.inc
+
+DESCRIPTION += "(version with Belkin support)"
+RCONFLICTS = "irk-targus"
+RREPLACES = "irk-targus"
+PR = "r2"
SRC_URI = "http://kopsisengineering.com/irk-current.tgz \
file://install-default-conf.patch;patch=1"
-S = "${WORKDIR}/irk"
-
-inherit palmtop
-
-EXTRA_QMAKEVARS_POST = "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
-
-do_install() {
- install -d ${D}${sysconfdir}/
- install -d ${D}${palmtopdir}/etc/skel/
- install -d ${D}${palmtopdir}/plugins/inputmethods/
-
- install -m 0644 chicony.conf ${D}${sysconfdir}/lircd.conf
- install -m 0644 IRK.conf ${D}${palmtopdir}/etc/skel/
- oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
-}
-
-FILES_${PN} += "${sysconfdir}"
diff --git a/packages/irk/irk-targus_0.11.0.bb b/packages/irk/irk-targus_0.11.0.bb
new file mode 100644
index 0000000000..d7ba4a70a8
--- /dev/null
+++ b/packages/irk/irk-targus_0.11.0.bb
@@ -0,0 +1,10 @@
+include irk.inc
+
+DESCRIPTION += "(version with Targus support)"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+
+RCONFLICTS = "irk-belkin"
+RREPLACES = "irk-belkin"
+
+SRC_URI = "http://angela1.data-uncertain.co.uk/~zaurus/irk-${PV}.tgz \
+ file://install-default-conf.patch;patch=1"
diff --git a/packages/irk/irk_0.11.bb b/packages/irk/irk.inc
index d21029807b..c988cdafd3 100644
--- a/packages/irk/irk_0.11.bb
+++ b/packages/irk/irk.inc
@@ -1,16 +1,10 @@
DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus."
SECTION = "opie/inputmethods"
PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
DEPENDS = "virtual/libqpe lirc"
-RCONFLICTS = "irk-belkin"
-RREPLACES = "irk-belkin"
-PR = "r2"
-REALV = "0.11.0"
-SRC_URI = "http://angela1.data-uncertain.co.uk/~zaurus/irk-${REALV}.tgz"
S = "${WORKDIR}/irk"
inherit palmtop
@@ -18,14 +12,13 @@ inherit palmtop
EXTRA_QMAKEVARS_POST = "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
do_install() {
- install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/
+ install -d ${D}${palmtopdir}/etc/skel/
install -d ${D}${palmtopdir}/plugins/inputmethods/
- install -d ${D}/home/root/Settings/
- install chicony.conf ${D}${sysconfdir}/lircd.conf
- install IRK.conf ${D}${sysconfdir}
+ install -m 0644 chicony.conf ${D}${sysconfdir}/lircd.conf
+ install -m 0644 IRK.conf ${D}${palmtopdir}/etc/skel/
oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
}
-FILES_irk_append=" /etc /home/root"
-
+FILES_${PN} += "${sysconfdir}"