aboutsummaryrefslogtreecommitdiffstats
path: root/packages/irk
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/irk
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/irk')
-rw-r--r--packages/irk/irk-belkin_0.11.bb31
-rw-r--r--packages/irk/irk_0.11.bb31
2 files changed, 62 insertions, 0 deletions
diff --git a/packages/irk/irk-belkin_0.11.bb b/packages/irk/irk-belkin_0.11.bb
index e69de29bb2..a8d6056914 100644
--- a/packages/irk/irk-belkin_0.11.bb
+++ b/packages/irk/irk-belkin_0.11.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus. (version with Belkin support instead of Targus)"
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "virtual/libqpe lirc"
+RDEPENDS = "lirc"
+RPROVIDES = "irk"
+RCONFLICTS = "irk"
+RREPLACES = "irk"
+PR = "r1"
+
+SRC_URI = "http://kopsisengineering.com/irk-current.tgz \
+ file://install-default-conf.patch;patch=1"
+S = "${WORKDIR}/irk"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST = "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
+
+do_install() {
+ install -d ${D}${sysconfdir}/
+ install -d ${D}${palmtopdir}/etc/skel/
+ install -d ${D}${palmtopdir}/plugins/inputmethods/
+
+ install -m 0644 chicony.conf ${D}${sysconfdir}/lircd.conf
+ install -m 0644 IRK.conf ${D}${palmtopdir}/etc/skel/
+ oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
+}
+
+FILES_${PN} += "${sysconfdir}"
diff --git a/packages/irk/irk_0.11.bb b/packages/irk/irk_0.11.bb
index e69de29bb2..687dee3b50 100644
--- a/packages/irk/irk_0.11.bb
+++ b/packages/irk/irk_0.11.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus."
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+DEPENDS = "virtual/libqpe lirc"
+RCONFLICTS = "irk-belkin"
+RREPLACES = "irk-belkin"
+PR = "r1"
+REALV = "0.11.0"
+
+SRC_URI = "http://angela1.data-uncertain.co.uk/~zaurus/irk-${REALV}.tgz"
+S = "${WORKDIR}/irk"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST = "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${palmtopdir}/plugins/inputmethods/
+ install -d ${D}home/root/Settings/
+
+ install chicony.conf ${D}${sysconfdir}/lircd.conf
+ install IRK.conf ${D}${sysconfdir}
+ oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
+}
+
+FILES_irk_append=" /etc /home/root"
+