aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth/ixp400-eth-1.4/makefile.patch
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-03 06:16:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-03 06:16:32 +0000
commit3045b0eff6c4690d4a92d84cda6a9ce9dec04e44 (patch)
tree80e9c7d6e332fd3ec1916833386d3120496a6ad4 /packages/ixp425-eth/ixp400-eth-1.4/makefile.patch
parent8ca15982a3387d4fa34e0b78382c8e2f48f3e1e4 (diff)
downloadopenembedded-3045b0eff6c4690d4a92d84cda6a9ce9dec04e44.tar.gz
ixp4xx, ixp425-eth: add Intel Access Library 2.0, ethernet driver 1.4
NOTE: to use these you must pin ixp4xx-csr, ixp-oxal and ixp400-eth. The name of the ethernet driver changes with this commit - it is now ixp400-eth, not ixp425-eth - changes are required in systems which need to use the ethernet driver and these changes are *not* in this commit. The things to change are the image (which must now depend on ixp400-eth) and any modprobe.conf (which, at least in NSLU2 - openslug-init - aliases eth0 as ixp4??-eth).
Diffstat (limited to 'packages/ixp425-eth/ixp400-eth-1.4/makefile.patch')
-rw-r--r--packages/ixp425-eth/ixp400-eth-1.4/makefile.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/ixp425-eth/ixp400-eth-1.4/makefile.patch b/packages/ixp425-eth/ixp400-eth-1.4/makefile.patch
new file mode 100644
index 0000000000..350485c1aa
--- /dev/null
+++ b/packages/ixp425-eth/ixp400-eth-1.4/makefile.patch
@@ -0,0 +1,33 @@
+--- /dev/null 2005-09-06 00:17:15.000000000 -0700
++++ ./Makefile 2005-10-02 22:15:19.974595551 -0700
+@@ -0,0 +1,30 @@
++obj-m := ixp400_eth.o
++
++CFLAGS_ixp400_eth.o = -DWall \
++ -I$(IXP4XX_CSR_DIR) \
++ -I$(OSAL_DIR)/ \
++ -I$(OSAL_DIR)/os/linux/include/ \
++ -I$(OSAL_DIR)/os/linux/include/modules/ \
++ -I$(OSAL_DIR)/os/linux/include/modules/ioMem/ \
++ -I$(OSAL_DIR)/os/linux/include/modules/core/ \
++ -I$(OSAL_DIR)/os/linux/include/modules/bufferMgt/ \
++ -I$(OSAL_DIR)/os/linux/include/core/ \
++ -I$(OSAL_DIR)/os/linux/include/platforms/ \
++ -I$(OSAL_DIR)/os/linux/include/platforms/ixp400/ \
++ -I$(OSAL_DIR)/os/linux/include/core/ \
++ -I$(OSAL_DIR)/include/ \
++ -I$(OSAL_DIR)/include/modules/ \
++ -I$(OSAL_DIR)/include/modules/bufferMgt/ \
++ -I$(OSAL_DIR)/include/modules/ioMem/ \
++ -I$(OSAL_DIR)/include/modules/core/ \
++ -I$(OSAL_DIR)/include/platforms/ \
++ -I$(OSAL_DIR)/include/platforms/ixp400/ \
++ -I$(OSAL_DIR)/include/platforms/ixp400/xp425/ \
++ -I$(OSAL_DIR)/os/linux/include/platforms/ixp400/ixp425/ \
++ $(IX_CFLAGS)
++
++default:
++ $(MAKE) ARCH=arm CROSS_COMPILE=$(LINUX_CROSS_COMPILE) V=1 -C $(LINUX_SRC) SUBDIRS=$(PWD) modules
++
++clean:
++ rm -f ixp400_eth.ko