aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth/ixp425-eth_1.2.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-01 08:12:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-01 08:12:28 +0000
commit24bad8ed028a8e075283c62d935dd0ec1344063e (patch)
tree61afd310286ad1bba9bb1b4e09ad4718393f8e21 /packages/ixp425-eth/ixp425-eth_1.2.bb
parent68c437628f2d561c87e6dfe2cdf07bd7bca44cd2 (diff)
downloadopenembedded-24bad8ed028a8e075283c62d935dd0ec1344063e.tar.gz
ixp intel drivers: ixp4xx v1.5 ixp425-eth v1.2
Diffstat (limited to 'packages/ixp425-eth/ixp425-eth_1.2.bb')
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/ixp425-eth/ixp425-eth_1.2.bb b/packages/ixp425-eth/ixp425-eth_1.2.bb
new file mode 100644
index 0000000000..fbb8a2f27c
--- /dev/null
+++ b/packages/ixp425-eth/ixp425-eth_1.2.bb
@@ -0,0 +1,45 @@
+# This is the Intel GPL IXP4XX ethernet driver (Linux) plus patches
+# to make it work on 2.6 kernels.
+#
+DEPENDS = "ixp4xx-csr"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SRC_URI = "ftp://download.intel.com/design/network/swsup/ixp400linuxethernetdriverpatch-1_2.zip"
+SRC_URI += "file://ixp400linuxethernetdriver-1_2-kernel26_hr_20050929.patch;patch=1"
+SRC_URI += "file://makefile.patch;patch=1"
+SRC_URI += "file://2.6.13.patch;patch=1"
+SRC_URI += "file://2.6.14.patch;patch=1"
+PR = "r0"
+
+S = "${WORKDIR}"
+
+COMPATIBLE_HOST = "^armeb-linux.*"
+
+inherit module
+
+# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
+# required. Notice that this has to be done for each separately built
+# module as well!
+KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
+KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
+
+# This is a somewhat arbitrary choice:
+OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"
+
+EXTRA_OEMAKE = "'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}' \
+ 'IXP4XX_CSR_DIR=${STAGING_INCDIR}/linux/ixp4xx-csr' \
+ 'OSAL_DIR=${OSAL_DIR}' \
+ 'LINUX_SRC=${STAGING_KERNEL_DIR}' \
+ 'LINUX_CROSS_COMPILE=${HOST_PREFIX}' \
+ "
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+ install -m 0644 ixp425_eth.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/
+}