aboutsummaryrefslogtreecommitdiffstats
path: root/packages/jhead
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2006-12-13 22:20:26 +0000
committerAndrew Wilcox <andy@protium.com>2006-12-13 22:20:26 +0000
commitacd63896986e7355cb6d1be79d2607436844c95a (patch)
tree273ba14ee58d1a01cfa60ed2eca9c52759f6ef23 /packages/jhead
parent69d2c71218d1e08cdf5837082c7d0bedc3da7df3 (diff)
downloadopenembedded-acd63896986e7355cb6d1be79d2607436844c95a.tar.gz
jhead: addition of jhead recipe
Diffstat (limited to 'packages/jhead')
-rw-r--r--packages/jhead/.mtn2git_empty0
-rw-r--r--packages/jhead/jhead_2.6.0.bb12
-rw-r--r--packages/jhead/makefile.patch22
3 files changed, 34 insertions, 0 deletions
diff --git a/packages/jhead/.mtn2git_empty b/packages/jhead/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/jhead/.mtn2git_empty
diff --git a/packages/jhead/jhead_2.6.0.bb b/packages/jhead/jhead_2.6.0.bb
new file mode 100644
index 0000000000..9089b6f46f
--- /dev/null
+++ b/packages/jhead/jhead_2.6.0.bb
@@ -0,0 +1,12 @@
+SECTION = "apps"
+
+S = ${WORKDIR}/jhead-2.6
+PR = "r0"
+SRC_URI = "http://www.sentex.net/~mwandel/jhead/jhead-2.6.tar.gz \
+ file://makefile.patch;patch=1"
+
+inherit autotools
+
+do_configure() {
+ :
+}
diff --git a/packages/jhead/makefile.patch b/packages/jhead/makefile.patch
new file mode 100644
index 0000000000..1d7b8e0f11
--- /dev/null
+++ b/packages/jhead/makefile.patch
@@ -0,0 +1,22 @@
+--- jhead-2.6/makefile 2006-04-29 16:14:59.000000000 -0700
++++ jhead-2.6/makefile 2006-08-17 07:59:14.000000000 -0700
+@@ -3,13 +3,18 @@
+ #--------------------------------
+ OBJ=.
+ SRC=.
++DESTDIR=/usr
++bindir=/bin
+
+ all: jhead
+
+ objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/exif.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+ $(OBJ)/%.o:$(SRC)/%.c
+- ${CC} -O3 -Wall -c $< -o $@
++ ${CC} ${CFLAGS} -c $< -o $@
+
+ jhead: $(objs) jhead.h
+ ${CC} -o jhead $(objs) -lm
++
++install: jhead
++ install -m 755 jhead $(DESTDIR)$(bindir)/jhead