aboutsummaryrefslogtreecommitdiffstats
path: root/packages/jpeg
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-03-14 19:16:03 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-03-14 19:16:03 +0000
commit71b5e93f49434129e7d22db612401e2658e40ab0 (patch)
tree7183506393d71155faec097a5a461000f8376c2d /packages/jpeg
parentf6b13d904d5100bda78a808359caac6e401a2104 (diff)
downloadopenembedded-71b5e93f49434129e7d22db612401e2658e40ab0.tar.gz
packages/jpeg/jpeg_6b.bb: Add patch that allows libjpeg to compile using libtool on varius architectures
Diffstat (limited to 'packages/jpeg')
-rw-r--r--packages/jpeg/jpeg-6b/libtool.patch49
-rw-r--r--packages/jpeg/jpeg_6b.bb9
2 files changed, 55 insertions, 3 deletions
diff --git a/packages/jpeg/jpeg-6b/libtool.patch b/packages/jpeg/jpeg-6b/libtool.patch
new file mode 100644
index 0000000000..c7fd858cfc
--- /dev/null
+++ b/packages/jpeg/jpeg-6b/libtool.patch
@@ -0,0 +1,49 @@
+--- /orig-makefile.cfg 2007-03-13 18:09:05.000000000 +0200
++++ /makefile.cfg 2007-03-13 21:42:33.000000000 +0200
+@@ -36,8 +36,10 @@
+ # To link any special libraries, add the necessary -l commands here.
+ LDLIBS= @LIBS@
+
++
+ # If using GNU libtool, LIBTOOL references it; if not, LIBTOOL is empty.
+ LIBTOOL = @LIBTOOL@
++
+ # $(O) expands to "lo" if using libtool, plain "o" if not.
+ # Similarly, $(A) expands to "la" or "a".
+ O = @O@
+@@ -55,7 +57,7 @@
+ # miscellaneous OS-dependent stuff
+ SHELL= /bin/sh
+ # linker
+-LN= @LN@
++LN= $(LIBTOOL) --tag=CC --mode=link $(CC)
+ # file deletion command
+ RM= rm -f
+ # directory creation command
+@@ -141,7 +143,7 @@
+
+ # How to compile with libtool.
+ @COM_LT@.c.lo:
+-@COM_LT@ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c $(srcdir)/$*.c
++@COM_LT@ $(LIBTOOL) --tag=CC --mode=compile $(CC) $(CFLAGS) -c $(srcdir)/$*.c
+
+ # How to use ansi2knr, when not using libtool.
+ @COM_A2K@.c.o:
+@@ -152,7 +154,7 @@
+ # How to use ansi2knr AND libtool.
+ @COM_A2K@.c.lo:
+ @COM_A2K@ ./ansi2knr $(srcdir)/$*.c knr/$*.c
+-@COM_A2K@ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c knr/$*.c
++@COM_A2K@ $(LIBTOOL) --mode=compile --tag=CC $(CC) $(CFLAGS) -c knr/$*.c
+ @COM_A2K@ $(RM) knr/$*.c
+
+ ansi2knr: ansi2knr.c
+@@ -169,7 +171,7 @@
+
+ # with libtool:
+ libjpeg.la: @A2K_DEPS@ $(LIBOBJECTS)
+- $(LIBTOOL) --mode=link $(CC) -o libjpeg.la $(LIBOBJECTS) \
++ $(LIBTOOL) --tag=CC --mode=link $(CC) -o libjpeg.la $(LIBOBJECTS) \
+ -rpath $(libdir) -version-info $(JPEG_LIB_VERSION) $(LDFLAGS)
+
+ # sample programs:
diff --git a/packages/jpeg/jpeg_6b.bb b/packages/jpeg/jpeg_6b.bb
index 8573789230..c93aadb6ab 100644
--- a/packages/jpeg/jpeg_6b.bb
+++ b/packages/jpeg/jpeg_6b.bb
@@ -7,12 +7,15 @@ DEPENDS = "libtool-cross"
RPROVIDES_${PN} = "jpeg"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian.patch;patch=1 \
file://ldflags.patch;patch=1 \
- file://paths.patch;patch=1"
+ file://paths.patch;patch=1 \
+ file://libtool.patch;patch=1 \
+ "
+
S = "${WORKDIR}/jpeg-${PV}"
inherit autotools
@@ -20,7 +23,7 @@ inherit autotools
EXTRA_OECONF="--enable-static --enable-shared"
EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"'
-CFLAGS_append = " -D_REENTRANT"
+CFLAGS_append = " -D_REENTRANT"
do_stage() {
install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h