aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kanjipad
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-07 10:45:29 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-07 10:45:29 +0000
commitb044b304bb97f2875654528e13fdaf0d1ad10fcf (patch)
tree28424ba94fb3528323da5ac49552955986bff125 /packages/kanjipad
parent7a8143305405433b9281348ba1ba696716817138 (diff)
downloadopenembedded-b044b304bb97f2875654528e13fdaf0d1ad10fcf.tar.gz
kanjipad: Add kpengine module which can be used by a number of packages.
Thanks to pH5 for doing most of the preliminary work.
Diffstat (limited to 'packages/kanjipad')
-rw-r--r--packages/kanjipad/.mtn2git_empty0
-rw-r--r--packages/kanjipad/files/.mtn2git_empty0
-rw-r--r--packages/kanjipad/files/Makefile-kpengine-only.patch38
-rw-r--r--packages/kanjipad/kanjipad.inc9
-rw-r--r--packages/kanjipad/kpengine_0.1.bb10
5 files changed, 57 insertions, 0 deletions
diff --git a/packages/kanjipad/.mtn2git_empty b/packages/kanjipad/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kanjipad/.mtn2git_empty
diff --git a/packages/kanjipad/files/.mtn2git_empty b/packages/kanjipad/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kanjipad/files/.mtn2git_empty
diff --git a/packages/kanjipad/files/Makefile-kpengine-only.patch b/packages/kanjipad/files/Makefile-kpengine-only.patch
new file mode 100644
index 0000000000..5ea650e4e7
--- /dev/null
+++ b/packages/kanjipad/files/Makefile-kpengine-only.patch
@@ -0,0 +1,38 @@
+--- kanjipad-2.0.0.orig/Makefile 2002-08-25 21:00:54 +0200
++++ kanjipad-2.0.0/Makefile 2005-08-07 23:04:03 +0200
+@@ -5,7 +5,7 @@
+ GTKLIBS=$(shell pkg-config --libs gtk+-2.0)
+ GLIBLIBS=$(shell pkg-config --libs glib-2.0)
+
+-PREFIX=/usr/local
++PREFIX=/usr
+ DATADIR=$(PREFIX)/share
+
+ # location in which binaries are installed
+@@ -28,7 +28,7 @@
+ OBJS = kpengine.o scoring.o util.o
+ CFLAGS = $(OPTIMIZE) $(GTKINC) -DFOR_PILOT_COMPAT -DKP_LIBDIR=\"$(LIBDIR)\" -DBINDIR=\"$(BINDIR)\"
+
+-all: kpengine kanjipad jdata.dat
++all: kpengine jdata.dat
+
+ scoring.o: jstroke/scoring.c
+ $(CC) -c -o scoring.o $(CFLAGS) -Ijstroke jstroke/scoring.c
+@@ -45,9 +45,8 @@
+ jdata.dat: jstroke/strokedata.h conv_jdata.pl
+ perl conv_jdata.pl < jstroke/strokedata.h > jdata.dat
+
+-install: kanjipad kpengine jdata.dat
++install: kpengine jdata.dat
+ install -d $(DESTDIR)$(BINDIR)
+- install -m 0755 kanjipad $(DESTDIR)$(BINDIR)/kanjipad
+ install -m 0755 kpengine $(DESTDIR)$(BINDIR)/kpengine
+ install -d $(DESTDIR)$(LIBDIR)
+ install -m 0644 jdata.dat $(DESTDIR)$(LIBDIR)/jdata.dat
+@@ -75,4 +74,4 @@
+ cd .. && \
+ rm -rf $$distdir
+
+-.PHONY: dist distcheck
+\ No newline at end of file
++.PHONY: dist distcheck
diff --git a/packages/kanjipad/kanjipad.inc b/packages/kanjipad/kanjipad.inc
new file mode 100644
index 0000000000..aecd130b82
--- /dev/null
+++ b/packages/kanjipad/kanjipad.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Hand-writing recognition for Japanese Kanji characters (no kana)"
+AUTHOR = "Owen Taylor <otaylor@fishsoup.net>"
+HOMEPAGE = "http://fishsoup.net/software/kanjipad/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI="http://fishsoup.net/software/kanjipad/kanjipad-2.0.0.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/packages/kanjipad/kpengine_0.1.bb b/packages/kanjipad/kpengine_0.1.bb
new file mode 100644
index 0000000000..0fa32faf13
--- /dev/null
+++ b/packages/kanjipad/kpengine_0.1.bb
@@ -0,0 +1,10 @@
+require kanjipad.inc
+
+SECTION = "libs"
+
+SRC_URI += "file://Makefile-kpengine-only.patch;patch=1"
+
+FILES = "${bindir}/kpengine ${datadir}"
+
+# would it be better to make this a part of kanjipad bb?
+S = ${WORKDIR}/kanjipad-2.0.0/