aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kdepimpi
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-06 13:44:47 +0000
committerMichael Krelin <hacker@klever.net>2007-05-06 13:44:47 +0000
commit606886c037f23d2c50e7e90a8fa8256cacd24396 (patch)
tree30b9af31e3a28d9aaba4da4c7594e4c4c2ad713b /packages/kdepimpi
parent8ecd0965364d9269bde7e613119181bf9f1d86e9 (diff)
downloadopenembedded-606886c037f23d2c50e7e90a8fa8256cacd24396.tar.gz
kdepimpi: fix the QMutexLocker build fix
- patch to provide the QMutexLocker implementation.
Diffstat (limited to 'packages/kdepimpi')
-rw-r--r--packages/kdepimpi/files/qt-mt.patch41
-rw-r--r--packages/kdepimpi/kdepimpi_2.2.7.bb3
2 files changed, 43 insertions, 1 deletions
diff --git a/packages/kdepimpi/files/qt-mt.patch b/packages/kdepimpi/files/qt-mt.patch
new file mode 100644
index 0000000000..c7e3f9d88a
--- /dev/null
+++ b/packages/kdepimpi/files/qt-mt.patch
@@ -0,0 +1,41 @@
+diff --git a/microkde/kresources/resource.cpp b/microkde/kresources/resource.cpp
+index cccd485..65d82e2 100644
+--- a/microkde/kresources/resource.cpp
++++ b/microkde/kresources/resource.cpp
+@@ -29,6 +29,23 @@
+
+ using namespace KRES;
+
++namespace fixme {
++ class QMutexLocker {
++ public:
++ QMutexLocker(QMutex *m) : mtx(m) {
++ if(mtx) mtx->lock();
++ }
++ ~QMutexLocker() {
++ if(mtx) mtx->unlock();
++ }
++
++ QMutex *mutex() const { return mtx; }
++ private:
++ QMutex *mtx;
++ };
++}
++using namespace fixme;
++
+ class Resource::ResourcePrivate
+ {
+ public:
+diff --git a/microkde/kresources/resource.h b/microkde/kresources/resource.h
+index ed5af96..997fff6 100644
+--- a/microkde/kresources/resource.h
++++ b/microkde/kresources/resource.h
+@@ -25,7 +25,7 @@
+
+ //US
+ #ifdef QT_THREAD_SUPPORT
+-#include <qmutex.h>
++#include <qthread.h>
+ #endif //QT_THREAD_SUPPORT
+
+ #include <qvaluelist.h>
diff --git a/packages/kdepimpi/kdepimpi_2.2.7.bb b/packages/kdepimpi/kdepimpi_2.2.7.bb
index 6059bf8528..ca4d5c0786 100644
--- a/packages/kdepimpi/kdepimpi_2.2.7.bb
+++ b/packages/kdepimpi/kdepimpi_2.2.7.bb
@@ -1,5 +1,6 @@
SRC_URI = "${SOURCEFORGE_MIRROR}/kdepimpi/kdepimpi-${PV}.tar.gz \
- file://gcc4.patch;patch=1"
+ file://gcc4.patch;patch=1 \
+ file://qt-mt.patch;patch=1"
require kdepimpi-base.inc