aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kexecboot
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-08-04 13:12:22 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-08-04 13:12:22 +0000
commit7efe32a8489c41f1fedb5bcca5b4ffdbc4713359 (patch)
tree077efcbed5c7e72bb0d6283e517baa28a402f7a4 /packages/kexecboot
parent2f3a8dec220aeb3c9dcd2b661cda56bb9abdbf6d (diff)
downloadopenembedded-7efe32a8489c41f1fedb5bcca5b4ffdbc4713359.tar.gz
kexecboot-initramfs: wait some seconds before startup
linux-kexecboot: remove debug output kexecboot: pass rootdelay to all kernels
Diffstat (limited to 'packages/kexecboot')
-rw-r--r--packages/kexecboot/initramfs-kexecboot-image.bb2
-rw-r--r--packages/kexecboot/initramfs-kexecboot_1.0.bb13
-rw-r--r--packages/kexecboot/kexecboot_0.3.bb6
-rw-r--r--packages/kexecboot/linux-kexecboot-2.6.26/defconfig-collie4
-rw-r--r--packages/kexecboot/linux-kexecboot_2.6.26.bb3
5 files changed, 18 insertions, 10 deletions
diff --git a/packages/kexecboot/initramfs-kexecboot-image.bb b/packages/kexecboot/initramfs-kexecboot-image.bb
index a55601955a..e0434b5fbd 100644
--- a/packages/kexecboot/initramfs-kexecboot-image.bb
+++ b/packages/kexecboot/initramfs-kexecboot-image.bb
@@ -5,5 +5,5 @@ inherit image
export IMAGE_BASENAME = "initramfs-kexecboot-image"
-IMAGE_INSTALL = "klibc-utils-static-sh klibc-utils-static-mount kexec-static initramfs-kexecboot"
+IMAGE_INSTALL = "initramfs-kexecboot"
IMAGE_LINGUAS = ""
diff --git a/packages/kexecboot/initramfs-kexecboot_1.0.bb b/packages/kexecboot/initramfs-kexecboot_1.0.bb
index e1337419b8..75fb8e8708 100644
--- a/packages/kexecboot/initramfs-kexecboot_1.0.bb
+++ b/packages/kexecboot/initramfs-kexecboot_1.0.bb
@@ -1,11 +1,18 @@
DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
-PR = "r6"
-RDEPENDS = "kexecboot"
+PR = "r7"
+RDEPENDS = "kexecboot klibc-utils-static-mount klibc-utils-static-sh klibc-utils-static-sleep"
+
+FBANGLE = "270"
+INPUTDEV = "/dev/event0"
+
+
do_compile() {
cat > init.sh << EOF
#!/bin/sh
+/bin/sleep 3
/bin/mount -t proc proc /proc
-/usr/bin/kexecboot -a 270 -i /dev/event0
+echo "0 4 1 7" > /proc/sys/kernel/printk
+/usr/bin/kexecboot -a ${FBANGLE} -i ${INPUTDEV}
EOF
}
diff --git a/packages/kexecboot/kexecboot_0.3.bb b/packages/kexecboot/kexecboot_0.3.bb
index 89b9e3b415..f3fb6e35cb 100644
--- a/packages/kexecboot/kexecboot_0.3.bb
+++ b/packages/kexecboot/kexecboot_0.3.bb
@@ -1,12 +1,14 @@
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
DEPENDS = "klibc"
+RDEPENDS = "kexec-static"
inherit autotools
# You can create your own *-img.h by doing
# ./make-image-header.sh <file>.png HAND
-SRC_URI = "http://projects.linuxtogo.org/frs/download.php/221/kexecboot-${PV}.tar.gz"
+SRC_URI = "http://projects.linuxtogo.org/frs/download.php/221/kexecboot-${PV}.tar.gz \
+ file://rootdelay.patch;patch=1"
S = "${WORKDIR}/kexecboot-${PV}"
diff --git a/packages/kexecboot/linux-kexecboot-2.6.26/defconfig-collie b/packages/kexecboot/linux-kexecboot-2.6.26/defconfig-collie
index 096050a3ae..7a22aa4ee1 100644
--- a/packages/kexecboot/linux-kexecboot-2.6.26/defconfig-collie
+++ b/packages/kexecboot/linux-kexecboot-2.6.26/defconfig-collie
@@ -251,7 +251,7 @@ CONFIG_ALIGNMENT_TRAP=y
#
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZBOOT_ROM_BSS=0x0
-CONFIG_CMDLINE="console=ttySA0,115200n8 console=tty1 noinitrd root=/dev/mtdblock2 rootfstype=jffs2 rootdelay=3 mem=64M fbcon=rotate:1 dyntick=enable"
+CONFIG_CMDLINE="console=ttySA0,115200n8 noinitrd root=/dev/mtdblock2 rootfstype=jffs2 rootdelay=3 mem=64M fbcon=rotate:1 dyntick=enable"
# CONFIG_XIP_KERNEL is not set
CONFIG_KEXEC=y
CONFIG_ATAGS_PROC=y
@@ -398,7 +398,7 @@ CONFIG_BLK_DEV_IDE=y
# Please see Documentation/ide/ide.txt for help/info on IDE drives
#
# CONFIG_BLK_DEV_IDE_SATA is not set
-# CONFIG_BLK_DEV_IDEDISK is not set
+CONFIG_BLK_DEV_IDEDISK=y
# CONFIG_IDEDISK_MULTI_MODE is not set
CONFIG_BLK_DEV_IDECS=y
# CONFIG_BLK_DEV_IDECD is not set
diff --git a/packages/kexecboot/linux-kexecboot_2.6.26.bb b/packages/kexecboot/linux-kexecboot_2.6.26.bb
index d7e97a8187..5d31aae5cb 100644
--- a/packages/kexecboot/linux-kexecboot_2.6.26.bb
+++ b/packages/kexecboot/linux-kexecboot_2.6.26.bb
@@ -1,7 +1,6 @@
require linux-kexecboot.inc
-PR = "r1"
-FILESDIR = "linux-rp_${PV}"
+PR = "r2"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_qemuarm = "-1"
DEFAULT_PREFERENCE_qemux86 = "-1"