aboutsummaryrefslogtreecommitdiffstats
path: root/packages/keylaunch
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-03-09 14:29:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-09 14:29:55 +0000
commit0db04b9285c8c05f307bd5dbb0a77be43385bc7d (patch)
tree1d1e2f7301e843b09b7d8c248ee69e6cde4b0301 /packages/keylaunch
parent9e6c7c1c443ae075965b26a11f7155bd895c5e6c (diff)
downloadopenembedded-0db04b9285c8c05f307bd5dbb0a77be43385bc7d.tar.gz
keylaunch-2.0.7: LDFLAGS Makefile fix
Diffstat (limited to 'packages/keylaunch')
-rw-r--r--packages/keylaunch/files/makefile-fix.patch11
-rw-r--r--packages/keylaunch/keylaunch_2.0.7.bb3
2 files changed, 13 insertions, 1 deletions
diff --git a/packages/keylaunch/files/makefile-fix.patch b/packages/keylaunch/files/makefile-fix.patch
new file mode 100644
index 0000000000..52260bf4de
--- /dev/null
+++ b/packages/keylaunch/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- keylaunch-2.0.7/Makefile.orig 2006-02-02 17:44:53.000000000 +0100
++++ keylaunch-2.0.7/Makefile 2006-02-02 17:44:55.000000000 +0100
+@@ -28,7 +28,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBS) -o $@
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ install-program: all
+ install -sD $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
diff --git a/packages/keylaunch/keylaunch_2.0.7.bb b/packages/keylaunch/keylaunch_2.0.7.bb
index 37b1dbcf46..42921dfcdc 100644
--- a/packages/keylaunch/keylaunch_2.0.7.bb
+++ b/packages/keylaunch/keylaunch_2.0.7.bb
@@ -11,7 +11,8 @@ DESCRIPTION = "A small utility for binding commands to a hot key.\
rather than just running another copy."
PR = "r1"
-SRC_URI += " file://keylaunchrc"
+SRC_URI += " file://keylaunchrc \
+ file://makefile-fix.patch;patch=1"
do_install_prepend () {
install ${WORKDIR}/keylaunchrc ${S}/keylaunchrc