aboutsummaryrefslogtreecommitdiffstats
path: root/packages/keylaunch
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-05-28 16:56:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-28 16:56:51 +0000
commitdb176af0bf1987aac2502954576d9265a92b80fe (patch)
tree237dd91cc2e1d457b20e856dbb49621a72585615 /packages/keylaunch
parent7c20a4dd2907fe24ba1967344e95eb1e2948d358 (diff)
downloadopenembedded-db176af0bf1987aac2502954576d9265a92b80fe.tar.gz
keylaunch: Akita / Spitz: Update keymapping to allow switching to the VT from inside X with Fn+Left or Fn+Right. Also includes a new script to make chvt SUID root to allow users to switch VTs
Diffstat (limited to 'packages/keylaunch')
-rw-r--r--packages/keylaunch/files/80chvt-SUID25
-rw-r--r--packages/keylaunch/files/akita/keylaunchrc4
-rw-r--r--packages/keylaunch/files/spitz/keylaunchrc4
-rw-r--r--packages/keylaunch/keylaunch_2.0.10.bb2
4 files changed, 34 insertions, 1 deletions
diff --git a/packages/keylaunch/files/80chvt-SUID b/packages/keylaunch/files/80chvt-SUID
new file mode 100644
index 0000000000..e3b4efef5d
--- /dev/null
+++ b/packages/keylaunch/files/80chvt-SUID
@@ -0,0 +1,25 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: chvt-SUID.sh
+# Date: 28-May-06
+
+
+#
+# Sets the SUID bit on chvt to allow changing to the VT from inside X by
+# any user. Since a SUID binary still is a security risk, we chmod only
+# when keylaunch is used and not by default.
+#
+
+for target in /usr/bin/chvt.console-tools
+do
+ if test "`ls -l "$target" | awk '{print $1}'|cut -c 2-4`" != "rws"
+ then
+ echo "Making [$target] SUID root..."
+ chmod u+s "$target"
+ else
+ echo "Ignoring [$target]"
+ fi
+done
diff --git a/packages/keylaunch/files/akita/keylaunchrc b/packages/keylaunch/files/akita/keylaunchrc
index 0379c719c4..27cce24e93 100644
--- a/packages/keylaunch/files/akita/keylaunchrc
+++ b/packages/keylaunch/files/akita/keylaunchrc
@@ -22,3 +22,7 @@ key=....F18:-:gpe-calendar
#key=....F19:-:
#key=....F19:-:
#key=....F10:-:
+
+# VT changing
+key=...*Left:-:~chvt 1
+key=...*Right:-:~chvt 3
diff --git a/packages/keylaunch/files/spitz/keylaunchrc b/packages/keylaunch/files/spitz/keylaunchrc
index f5e1fd70be..433221a586 100644
--- a/packages/keylaunch/files/spitz/keylaunchrc
+++ b/packages/keylaunch/files/spitz/keylaunchrc
@@ -22,3 +22,7 @@ key=....F18:-:gpe-calendar
#key=....F19:-:
#key=....F19:-:
#key=....F10:-:
+
+# VT changing
+key=...*Left:-:~chvt 1
+key=...*Right:-:~chvt 3
diff --git a/packages/keylaunch/keylaunch_2.0.10.bb b/packages/keylaunch/keylaunch_2.0.10.bb
index c06c9c4587..67ed0923f2 100644
--- a/packages/keylaunch/keylaunch_2.0.10.bb
+++ b/packages/keylaunch/keylaunch_2.0.10.bb
@@ -13,7 +13,7 @@ DESCRIPTION = "A small utility for binding commands to a hot key.\
program is already running, keylaunch can bring its window to the front\
rather than just running another copy."
PACKAGE_ARCH = "${MACHINE_ARCH}"
-PR = "r4"
+PR = "r5"
SRC_URI += " file://keylaunchrc"