aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kf
diff options
context:
space:
mode:
authorNicolas Ferre <nicolasfr@gmail.com>2006-12-03 14:39:58 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-03 14:39:58 +0000
commit7efa833ec6407079e58bbb51b6979be0aa95eca4 (patch)
tree78439871d23e0092e9fe210d1eb8d5f56da95b95 /packages/kf
parent4c54e301d475c4faab9b4234bd029a14c793a3dc (diff)
downloadopenembedded-7efa833ec6407079e58bbb51b6979be0aa95eca4.tar.gz
kf: patch to make it buildable with gcc4 - close #1523
Diffstat (limited to 'packages/kf')
-rw-r--r--packages/kf/files/gcc4.patch30
-rwxr-xr-xpackages/kf/kf_0.5.4.1.bb11
2 files changed, 36 insertions, 5 deletions
diff --git a/packages/kf/files/gcc4.patch b/packages/kf/files/gcc4.patch
new file mode 100644
index 0000000000..58727ea0e0
--- /dev/null
+++ b/packages/kf/files/gcc4.patch
@@ -0,0 +1,30 @@
+Index: kf-0.5.4.1/src/jispman.c
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.c 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.c 2006-12-03 15:35:01.000000000 +0100
+@@ -25,12 +25,6 @@
+ #include "emoticons.h"
+ #include "kf.h"
+
+-struct _KfJispManager {
+- GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
+- GList *patterns; /** A list of patterns */
+-};
+-
+-
+ /**
+ * \brief create a new instance of KfJispManager
+ * \return a new instance of KfJispManager
+Index: kf-0.5.4.1/src/jispman.h
+===================================================================
+--- kf-0.5.4.1.orig/src/jispman.h 2006-12-03 15:33:47.000000000 +0100
++++ kf-0.5.4.1/src/jispman.h 2006-12-03 15:34:37.000000000 +0100
+@@ -25,6 +25,8 @@
+ #include "jisp.h"
+
+ typedef struct _KfJispManager {
++ GHashTable *jisps; /** A hash-table of all JISP pachages managed by this object, indexed by their filename */
++ GList *patterns; /** A list of patterns */
+ } KfJispManager;
+
+ /**
diff --git a/packages/kf/kf_0.5.4.1.bb b/packages/kf/kf_0.5.4.1.bb
index 4cfd685f43..f171bb8b81 100755
--- a/packages/kf/kf_0.5.4.1.bb
+++ b/packages/kf/kf_0.5.4.1.bb
@@ -1,15 +1,16 @@
+DESCRIPTION = "Kf is a GTK+ instant messaging client."
LICENSE = "GPL"
DEPENDS = "libxml2 glib-2.0 gtk+ loudmouth"
-DESCRIPTION = "Kf is a GTK+ instant messaging client."
-PR = "r2"
+PR = "r3"
SRC_URI = "http://jabberstudio.2nw.net/${PN}/${PN}-${PV}.tar.gz \
file://fix-configure.patch;patch=1 \
- file://fix-desktop-file.patch;patch=0"
+ file://fix-desktop-file.patch;patch=0 \
+ file://gcc4.patch;patch=1"
inherit autotools pkgconfig
-export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
-
EXTRA_OECONF = "--disable-binreloc"
+export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
+