aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kismet/kismet_2007-01-R1b.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-03-03 01:12:39 +0000
committerMatthias Hentges <oe@hentges.net>2007-03-03 01:12:39 +0000
commit55146c2d9c56834bff391e73c0aecb0b816219e9 (patch)
tree8068098cee7120ad81c10d45b217897ecbb194ed /packages/kismet/kismet_2007-01-R1b.bb
parentdb48d32c5647e8167a7a55aa4bf10521dcf07a32 (diff)
downloadopenembedded-55146c2d9c56834bff391e73c0aecb0b816219e9.tar.gz
kismet: Add new .bb from Bugzilla, closing bug #1933 by Zero_Chaos, thanks!
Diffstat (limited to 'packages/kismet/kismet_2007-01-R1b.bb')
-rw-r--r--packages/kismet/kismet_2007-01-R1b.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/kismet/kismet_2007-01-R1b.bb b/packages/kismet/kismet_2007-01-R1b.bb
new file mode 100644
index 0000000000..774e71e286
--- /dev/null
+++ b/packages/kismet/kismet_2007-01-R1b.bb
@@ -0,0 +1,28 @@
+SECTION = "console/network"
+DESCRIPTION = "Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+HOMEPAGE = "http://www.kismetwireless.net/"
+LICENSE = "GPLv2"
+DEPENDS = "expat gmp"
+
+SRC_URI = "http://www.kismetwireless.net/code/kismet-2007-01-R1b.tar.gz \
+ file://no-chmod.patch;patch=1"
+
+
+EXTRA_OECONF = "--with-pcap=linux --disable-setuid --with-linuxheaders=${STAGING_KERNEL_DIR}/include"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_install_append() {
+ if test -e ${WORKDIR}/kismet.conf; then
+ install -m 644 ${WORKDIR}/kismet.conf ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGES =+ "kismet-sounds"
+FILES_kismet-sounds = "/usr/share/kismet/wav"
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/kismet.conf"