aboutsummaryrefslogtreecommitdiffstats
path: root/packages/knights
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-01-07 18:25:55 +0000
committerHolger Freyther <zecke@selfish.org>2008-01-07 18:25:55 +0000
commit484aec6e78dd9624f20779130565d1774d5b9e9f (patch)
tree669af5386d34b447d37985fb5ab095bf851c3a68 /packages/knights
parentd1631785248a72bb4d02cd55307b2a994fa5673a (diff)
downloadopenembedded-484aec6e78dd9624f20779130565d1774d5b9e9f.tar.gz
Bashism fix: echo -e is a bashism and doesn't work when /bin/sh points to dash
Instead of using "echo -e" we simply use printf. printf doesn't add a newline by default. So some places needed an extra \n in their string. Most of the change was done by hand, so please carefully review. This bug was spotted when trying to compile python-pyqt on my ubuntu hardy system.
Diffstat (limited to 'packages/knights')
-rw-r--r--packages/knights/knights_1.14.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/knights/knights_1.14.bb b/packages/knights/knights_1.14.bb
index 1e0766a7c7..dc3e026376 100644
--- a/packages/knights/knights_1.14.bb
+++ b/packages/knights/knights_1.14.bb
@@ -17,7 +17,7 @@ inherit palmtop
QMAKE_PROFILES = "knights.pro"
do_configure_prepend() {
- echo -e "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
+ printf "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
}
do_install() {