aboutsummaryrefslogtreecommitdiffstats
path: root/packages/knights
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-02-11 10:50:00 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2005-02-11 10:50:00 +0000
commitda0eb5975c6c9bfef7d0fdeb1ea7a6bbf0caaf90 (patch)
tree4e2724ecffa3db9d259473bc8e531ce3bbcabad6 /packages/knights
parentf9a26d6f19dc9adc734ef2e55fbc36f9acd7082d (diff)
downloadopenembedded-da0eb5975c6c9bfef7d0fdeb1ea7a6bbf0caaf90.tar.gz
knights: added build time dependency on phalanx to get all needed packages ready to use after build
BKrev: 420c8dd8yt_PuksyuRZapfIA2t2FLA
Diffstat (limited to 'packages/knights')
-rw-r--r--packages/knights/knights_1.14.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/knights/knights_1.14.bb b/packages/knights/knights_1.14.bb
index e69de29bb2..9d35e64b68 100644
--- a/packages/knights/knights_1.14.bb
+++ b/packages/knights/knights_1.14.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Chess Game for Qt/Embedded based palmtop environments. \
+Uses the Phalanx chess engine."
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "phalanx"
+RDEPENDS = "phalanx"
+PR = "r2"
+
+SRC_URI = "http://www.houseoffish.org/knights/downloads/knights.tar.gz \
+ file://libqpe-opie.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/knights"
+
+inherit palmtop
+
+QMAKE_PROFILES = "knights.pro"
+
+do_configure_prepend() {
+ echo -e "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
+}
+
+do_install() {
+ install -d ${D}/${palmtopdir}/bin \
+ ${D}/${palmtopdir}/apps/Games \
+ ${D}/${palmtopdir}/pics
+ install -D -m 755 knights/knights ${D}/${palmtopdir}/bin/knights
+ install -D -m 644 knights.desktop ${D}/${palmtopdir}/apps/Games/knights.desktop
+ install -d ${D}/${palmtopdir}/pics
+ cp -a pics/knights ${D}/${palmtopdir}/pics/
+}