aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libaal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/libaal
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/libaal')
-rw-r--r--packages/libaal/.mtn2git_empty0
-rw-r--r--packages/libaal/libaal_1.0.4.bb26
2 files changed, 26 insertions, 0 deletions
diff --git a/packages/libaal/.mtn2git_empty b/packages/libaal/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libaal/.mtn2git_empty
diff --git a/packages/libaal/libaal_1.0.4.bb b/packages/libaal/libaal_1.0.4.bb
index e69de29bb2..e8956bd7d4 100644
--- a/packages/libaal/libaal_1.0.4.bb
+++ b/packages/libaal/libaal_1.0.4.bb
@@ -0,0 +1,26 @@
+# This is the support library for reiser4progs, required when
+# building that package. The libraries from this build must
+# be installed on the system to use the reiser4progs programs
+PR = "r0"
+DESCRIPTION = "Library for user-level code accessing Reiser4 filesystems"
+HOMEPAGE = "http://www.namesys.com"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "base"
+LICENSE = "GPL-2"
+
+SRC_URI = "ftp://ftp.namesys.com/pub/reiser4progs/${P}.tar.gz"
+
+inherit autotools
+
+# This disables anything which uses libminimal - that library
+# is used for boot loader stuff and so is not required unless
+# the system will boot from a Reiser4 file system, the same
+# setting must exist for the reiser4progs build
+DISABLE_LIBMINIMAL ?= "--disable-libminimal"
+EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
+
+do_stage() {
+ echo "NOTE: stage package ${PF} is: (${PN},${PV},${PR})"
+ autotools_stage_includes
+ oe_libinstall -a -so -C src ${PN} ${STAGING_LIBDIR}
+}