aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libaio
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-14 18:41:18 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-14 18:41:18 +0000
commit82c1da2b581162386d8ec5ff0e707c9c3e5578a6 (patch)
tree9af9f23ec6cdf79fe1d51351191c124076846b04 /packages/libaio
parent9ad16bc2804fe0ddc38666aa5626f6ec44332bbf (diff)
downloadopenembedded-82c1da2b581162386d8ec5ff0e707c9c3e5578a6.tar.gz
libaio: added hack to get rid of undefined reference to '__io_getevents_0_4'
Diffstat (limited to 'packages/libaio')
-rw-r--r--packages/libaio/libaio-0.3.106/__io_getevents_0_4.patch29
-rw-r--r--packages/libaio/libaio_0.3.106.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/packages/libaio/libaio-0.3.106/__io_getevents_0_4.patch b/packages/libaio/libaio-0.3.106/__io_getevents_0_4.patch
new file mode 100644
index 0000000000..ce4578515c
--- /dev/null
+++ b/packages/libaio/libaio-0.3.106/__io_getevents_0_4.patch
@@ -0,0 +1,29 @@
+From: Marcin Juszkiewicz <hrw@openembedded.org>
+
+Fast hack to get applications which use libaio linked.
+
+Get rid of:
+/home/hrw/devel/build/dev/tmp/staging/arm-linux/lib/libaio.so: undefined reference to `__io_getevents_0_4'
+
+Index: libaio-0.3.106/src/io_getevents.c
+===================================================================
+--- libaio-0.3.106.orig/src/io_getevents.c 2003-06-18 21:58:21.000000000 +0200
++++ libaio-0.3.106/src/io_getevents.c 2006-10-14 19:42:49.000000000 +0200
+@@ -22,7 +22,7 @@
+ #include <time.h>
+ #include "syscall.h"
+
+-io_syscall5(int, __io_getevents_0_4, io_getevents, io_context_t, ctx, long, min_nr, long, nr, struct io_event *, events, struct timespec *, timeout)
++io_syscall5(int, io_getevents_0_4, io_getevents, io_context_t, ctx, long, min_nr, long, nr, struct io_event *, events, struct timespec *, timeout)
+
+ #define AIO_RING_MAGIC 0xa10a10a1
+
+@@ -51,7 +51,7 @@
+ }
+
+ do_syscall:
+- return __io_getevents_0_4(ctx, min_nr, nr, events, timeout);
++ return io_getevents_0_4(ctx, min_nr, nr, events, timeout);
+ }
+
+ DEFSYMVER(io_getevents_0_4, io_getevents, 0.4)
diff --git a/packages/libaio/libaio_0.3.106.bb b/packages/libaio/libaio_0.3.106.bb
index edbc125180..e4d758c368 100644
--- a/packages/libaio/libaio_0.3.106.bb
+++ b/packages/libaio/libaio_0.3.106.bb
@@ -1,9 +1,11 @@
DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
LICENSE = "LGPL"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/liba/libaio/libaio_${PV}.orig.tar.gz \
file://00_arches.patch;patch=1 \
- file://destdir.patch;patch=1"
+ file://__io_getevents_0_4.patch;patch=1 \
+ file://destdir.patch;patch=1"
do_stage() {
install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}