aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libao
diff options
context:
space:
mode:
authorMatthias Goebl <oe@m.goebl.net>2006-02-05 23:21:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-05 23:21:41 +0000
commit64e88ccf6b78e01b5f53a21a026f855ed7783716 (patch)
treebfec529707cd8f3cef36affaa44c6b8364d0bb69 /packages/libao
parentf4156198b0d0399792402508b2d0854f106765b0 (diff)
downloadopenembedded-64e88ccf6b78e01b5f53a21a026f855ed7783716.tar.gz
libao-alsa_0.8.6: Add libao plugin-package with alsa support
- Make libao-alsa_0.8.6 from libao-alsa_0.8.6 and add alsa config and dependencies for plugin
Diffstat (limited to 'packages/libao')
-rw-r--r--packages/libao/libao-alsa_0.8.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/libao/libao-alsa_0.8.6.bb b/packages/libao/libao-alsa_0.8.6.bb
new file mode 100644
index 0000000000..4df98e1cca
--- /dev/null
+++ b/packages/libao/libao-alsa_0.8.6.bb
@@ -0,0 +1,27 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library. This is the ALSA plugin."
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Matthias Goebl <matthias.goebl@goebl.net>"
+DEPENDS = "alsa-lib libao"
+RDEPENDS = "libao2 (>=${PV})"
+PR = "r1"
+
+SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
+S = "${WORKDIR}/libao-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-oss \
+ --enable-alsa09 --enable-alsa09-mmap \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+}
+
+PACKAGES = "libao-alsa-plugin libao-alsa-plugin-dev"
+FILES_libao-alsa-plugin= "${libdir}/ao/plugins-2/libalsa*.so"
+FILES_libao-alsa-plugin-dev += "${libdir}/ao/plugins-2/libalsa*.la"