aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libdotconf
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-01-04 04:40:14 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-01-04 04:40:14 +0000
commit31634521405243e9933606d4654b3cac8c672fba (patch)
tree5b296c4f603f0d3020e026f43a8308ecb688cfff /packages/libdotconf
parent149538f4e797a0c530f3cbc6ffa1105613ad2053 (diff)
downloadopenembedded-31634521405243e9933606d4654b3cac8c672fba.tar.gz
dotconf: rename to libdotonf, fix packaging
* follow debian naming and packaging * change dependency in speech-dispatcher
Diffstat (limited to 'packages/libdotconf')
-rw-r--r--packages/libdotconf/.mtn2git_empty0
-rw-r--r--packages/libdotconf/files/.mtn2git_empty0
-rw-r--r--packages/libdotconf/files/srcMakefile.am_00.patch9
-rw-r--r--packages/libdotconf/libdotconf_1.0.13.bb25
4 files changed, 34 insertions, 0 deletions
diff --git a/packages/libdotconf/.mtn2git_empty b/packages/libdotconf/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libdotconf/.mtn2git_empty
diff --git a/packages/libdotconf/files/.mtn2git_empty b/packages/libdotconf/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libdotconf/files/.mtn2git_empty
diff --git a/packages/libdotconf/files/srcMakefile.am_00.patch b/packages/libdotconf/files/srcMakefile.am_00.patch
new file mode 100644
index 0000000000..500f1fd2d7
--- /dev/null
+++ b/packages/libdotconf/files/srcMakefile.am_00.patch
@@ -0,0 +1,9 @@
+--- dotconf-1.0.13/src/Makefile.am.orig 2008-01-02 11:48:16.000000000 +0000
++++ dotconf-1.0.13/src/Makefile.am 2008-01-02 11:48:22.000000000 +0000
+@@ -1,5 +1,5 @@
+
+-INCLUDES = -I. -I$(includedir)
++INCLUDES = -I.
+
+ include_HEADERS = dotconf.h
+ noinst_HEADERS = readdir.h
diff --git a/packages/libdotconf/libdotconf_1.0.13.bb b/packages/libdotconf/libdotconf_1.0.13.bb
new file mode 100644
index 0000000000..05520519b6
--- /dev/null
+++ b/packages/libdotconf/libdotconf_1.0.13.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = " dot.conf is an easy to use and powerful configuration file parser library"
+HOMEPAGE = "http://www.azzit.de/dotconf/"
+LICENSE = "LGPLv2"
+
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "http://www.azzit.de/dotconf/download/v1.0/dotconf-${PV}.tar.gz \
+ file://srcMakefile.am_00.patch;patch=1"
+
+S = "${WORKDIR}/dotconf-${PV}"
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+
+ install -m 0644 ${S}/src/dotconf.h ${D}${includedir}
+ oe_libinstall -C src -so libdotconf ${D}${libdir}
+}
+
+do_stage() {
+ install -m 0644 ${S}/src/dotconf.h ${STAGING_INCDIR}/
+ oe_libinstall -C src -so libdotconf ${STAGING_LIBDIR}/
+}