aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libexif
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-01-05 20:22:23 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-05 20:22:23 +0000
commitdb597c3e9002eb206723339f0bd40a92cc669be0 (patch)
tree8218c1c3c98046707685f70bcfda93cbbd76d380 /packages/libexif
parent4f7f516a8dc9031537c6c1a0e9ef3a93bc350c34 (diff)
downloadopenembedded-db597c3e9002eb206723339f0bd40a92cc669be0.tar.gz
libexif: revert deletion of do_stage() applied in 9c3da63504cf03581d04ad46a9797e04293b62e8
Diffstat (limited to 'packages/libexif')
-rw-r--r--packages/libexif/libexif_0.6.9.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/packages/libexif/libexif_0.6.9.bb b/packages/libexif/libexif_0.6.9.bb
index c40edc4c95..cd68bf1855 100644
--- a/packages/libexif/libexif_0.6.9.bb
+++ b/packages/libexif/libexif_0.6.9.bb
@@ -3,12 +3,18 @@ HOMEPAGE = "http://sourceforge.net/projects/libexif"
LICENSE = "LGPL"
SECTION = "libs"
MAINTAINER = "Eddy Pronk <epronk@muftor.com>"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
inherit autotools pkgconfig
do_stage() {
- autotools_stage_all
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h exif-log.h exif-mnote-data.h _stdint.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
}