aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libmad/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-02-04 14:06:41 +0000
committerKoen Kooi <koen@openembedded.org>2008-02-04 14:06:41 +0000
commite3d5d334b7ff999fe3e66e995ff9e94752e3814a (patch)
treefa38b0281aadfa6910974eb6a2e2de5087382762 /packages/libmad/files
parentbac34c58b1a65d5b9e6f3d43e3c8bc7eea4c797c (diff)
downloadopenembedded-e3d5d334b7ff999fe3e66e995ff9e94752e3814a.tar.gz
libmad: update avr32 patch
Diffstat (limited to 'packages/libmad/files')
-rw-r--r--packages/libmad/files/libmad-0.15.1b-avr32-optimization.patch62
1 files changed, 31 insertions, 31 deletions
diff --git a/packages/libmad/files/libmad-0.15.1b-avr32-optimization.patch b/packages/libmad/files/libmad-0.15.1b-avr32-optimization.patch
index f6620f591a..b74eea3225 100644
--- a/packages/libmad/files/libmad-0.15.1b-avr32-optimization.patch
+++ b/packages/libmad/files/libmad-0.15.1b-avr32-optimization.patch
@@ -139,20 +139,19 @@ index 5a51570..70f550a 100644
unsigned short mad_bit_crc(struct mad_bitptr, unsigned int, unsigned short);
# endif
-diff --git a/configure b/configure
-index ee421cc..7a9f0c8 100755
---- a/configure
-+++ b/configure
-@@ -1048,7 +1048,7 @@ Optional Features:
- --enable-speed optimize for speed over accuracy
- --enable-accuracy optimize for accuracy over speed
- --enable-fpm=ARCH use ARCH-specific fixed-point math routines (one of:
-- intel, arm, mips, sparc, ppc, 64bit, default)
-+ intel, arm, avr32, mips, sparc, ppc, 64bit, default)
- --enable-sso use subband synthesis optimization
- --disable-aso disable architecture-specific optimizations
- --enable-strict-iso use strict ISO/IEC interpretations
-@@ -21477,6 +21477,7 @@ if test "${enable_fpm+set}" = set; then
+diff --git a/configure.ac b/configure.ac
+index 9b79399..063cb9b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,13 +274,14 @@ fi
+ AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
+ AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
+ [use ARCH-specific fixed-point math routines
+- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
++ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
+ [
+ case "$enableval" in
+ yes) ;;
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
@@ -160,7 +159,7 @@ index ee421cc..7a9f0c8 100755
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
-@@ -21498,6 +21499,7 @@ then
+@@ -298,6 +299,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
@@ -168,7 +167,7 @@ index ee421cc..7a9f0c8 100755
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
-@@ -21554,6 +21556,11 @@ then
+@@ -343,6 +345,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;
@@ -180,19 +179,20 @@ index ee421cc..7a9f0c8 100755
mips*-*)
ASO="$ASO -DASO_INTERLEAVE2"
ASO="$ASO -DASO_ZEROCHECK"
-diff --git a/configure.ac b/configure.ac
-index 9b79399..063cb9b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -274,13 +274,14 @@ fi
- AC_MSG_CHECKING(for architecture-specific fixed-point math routines)
- AC_ARG_ENABLE(fpm, AC_HELP_STRING([--enable-fpm=ARCH],
- [use ARCH-specific fixed-point math routines
-- (one of: intel, arm, mips, sparc, ppc, 64bit, default)]),
-+ (one of: intel, arm, avr32, mips, sparc, ppc, 64bit, default)]),
- [
- case "$enableval" in
- yes) ;;
+diff --git a/configure b/configure
+index ee421cc..7a9f0c8 100755
+--- a/configure
++++ b/configure
+@@ -1048,7 +1048,7 @@ Optional Features:
+ --enable-speed optimize for speed over accuracy
+ --enable-accuracy optimize for accuracy over speed
+ --enable-fpm=ARCH use ARCH-specific fixed-point math routines (one of:
+- intel, arm, mips, sparc, ppc, 64bit, default)
++ intel, arm, avr32, mips, sparc, ppc, 64bit, default)
+ --enable-sso use subband synthesis optimization
+ --disable-aso disable architecture-specific optimizations
+ --enable-strict-iso use strict ISO/IEC interpretations
+@@ -21477,6 +21477,7 @@ if test "${enable_fpm+set}" = set; then
no|default|approx) FPM="DEFAULT" ;;
intel|i?86) FPM="INTEL" ;;
arm) FPM="ARM" ;;
@@ -200,7 +200,7 @@ index 9b79399..063cb9b 100644
mips) FPM="MIPS" ;;
sparc) FPM="SPARC" ;;
ppc|powerpc) FPM="PPC" ;;
-@@ -298,6 +299,7 @@ then
+@@ -21498,6 +21499,7 @@ then
case "$host" in
i?86-*) FPM="INTEL" ;;
arm*-*) FPM="ARM" ;;
@@ -208,7 +208,7 @@ index 9b79399..063cb9b 100644
mips*-*) FPM="MIPS" ;;
sparc*-*) FPM="SPARC" ;;
powerpc*-*) FPM="PPC" ;;
-@@ -343,6 +345,11 @@ then
+@@ -21554,6 +21556,11 @@ then
ASO="$ASO -DASO_IMDCT"
ASO_OBJS="imdct_l_arm.lo"
;;