aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libmrss
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-04-08 01:10:59 +0000
committerHolger Freyther <zecke@selfish.org>2007-04-08 01:10:59 +0000
commitf945894dd337e0ce7efd86f0910ca70c3f39399b (patch)
treeb9f205399850f61e8bf8cd8fe7be8a607799130c /packages/libmrss
parent387cf2194a683880eb95e0b42e9fd86fe7a6e165 (diff)
downloadopenembedded-f945894dd337e0ce7efd86f0910ca70c3f39399b.tar.gz
packages/libmrss: Correct the month of atom dates
Diffstat (limited to 'packages/libmrss')
-rw-r--r--packages/libmrss/files/.mtn2git_empty0
-rw-r--r--packages/libmrss/files/atom-right-date.patch15
-rw-r--r--packages/libmrss/libmrss_0.17.1.bb5
3 files changed, 18 insertions, 2 deletions
diff --git a/packages/libmrss/files/.mtn2git_empty b/packages/libmrss/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libmrss/files/.mtn2git_empty
diff --git a/packages/libmrss/files/atom-right-date.patch b/packages/libmrss/files/atom-right-date.patch
new file mode 100644
index 0000000000..ba231b2ab4
--- /dev/null
+++ b/packages/libmrss/files/atom-right-date.patch
@@ -0,0 +1,15 @@
+tm_mon goes from 0-11 written dates from 1-12. It is too late to consider security
+here. The worst that can happen is that tm_mon == 0 gets negative but I assume
+glibc to do range checking.
+Index: libmrss-0.17.1/src/mrss_parser.c
+===================================================================
+--- libmrss-0.17.1.orig/src/mrss_parser.c 2007-04-08 02:42:23.000000000 +0200
++++ libmrss-0.17.1/src/mrss_parser.c 2007-04-08 02:43:37.000000000 +0200
+@@ -150,6 +150,7 @@
+ {
+ char datebuf[256];
+ stm.tm_year -= 1900;
++ stm.tm_mon -= 1;
+
+ if (!data->c_locale
+ && !(data->c_locale = newlocale (LC_ALL_MASK, "C", NULL)))
diff --git a/packages/libmrss/libmrss_0.17.1.bb b/packages/libmrss/libmrss_0.17.1.bb
index fe2e87ca51..6476ee58c6 100644
--- a/packages/libmrss/libmrss_0.17.1.bb
+++ b/packages/libmrss/libmrss_0.17.1.bb
@@ -3,11 +3,12 @@ LICENSE = "LGPL"
HOMEPAGE = "http://www2.autistici.org/bakunin/codes.php"
DEPENDS = "libnxml curl"
-PR = "r0"
+PR = "r1"
inherit autotools pkgconfig
-SRC_URI = "http://www2.autistici.org/bakunin/libmrss/libmrss-${PV}.tar.gz"
+SRC_URI = "http://www2.autistici.org/bakunin/libmrss/libmrss-${PV}.tar.gz \
+ file://atom-right-date.patch;patch=1 "
do_stage() {
autotools_stage_all