aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libmutil
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/libmutil
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/libmutil')
-rw-r--r--packages/libmutil/libmutil0_0.2.2.bb23
-rw-r--r--packages/libmutil/libmutil0_svn.bb25
2 files changed, 48 insertions, 0 deletions
diff --git a/packages/libmutil/libmutil0_0.2.2.bb b/packages/libmutil/libmutil0_0.2.2.bb
index e69de29bb2..b6feff53f4 100644
--- a/packages/libmutil/libmutil0_0.2.2.bb
+++ b/packages/libmutil/libmutil0_0.2.2.bb
@@ -0,0 +1,23 @@
+LICENSE = LGPL
+
+DESCRIPTION = "Class library implementing utilities for C++ programming"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "openssl"
+
+inherit autotools
+
+SRC_URI = "http://www.minisip.org/snapshots/libmutil-${PV}.tar.gz"
+S="${WORKDIR}/libmutil-${PV}"
+
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = " ${libdir}/libmutil.so.0 ${libdir}/libmutil.so.0.0.0 "
+
+do_stage() {
+ oe_libinstall -a -so libmutil ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libmutil
+ install -m 0644 ${S}/include/libmutil/* ${STAGING_INCDIR}/libmutil
+}
diff --git a/packages/libmutil/libmutil0_svn.bb b/packages/libmutil/libmutil0_svn.bb
index e69de29bb2..31145983a7 100644
--- a/packages/libmutil/libmutil0_svn.bb
+++ b/packages/libmutil/libmutil0_svn.bb
@@ -0,0 +1,25 @@
+PV = "0.2.2svn${CVSDATE}"
+LICENSE = LGPL
+
+DESCRIPTION = "Class library implementing utilities for C++ programming"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "openssl"
+DEFAULT_PREFERENCE=-1
+
+inherit autotools
+
+SRC_URI = "svn://svn.minisip.org/var/svn/minisip/trunk;module=libmutil"
+S="${WORKDIR}/libmutil"
+
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = " ${libdir}/libmutil.so.0 ${libdir}/libmutil.so.0.0.0 "
+
+do_stage() {
+ oe_libinstall -a -so libmutil ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libmutil
+ install -m 0644 ${S}/include/libmutil/* ${STAGING_INCDIR}/libmutil
+}